"Versão mínima suportada do Gradle é 2.14.1. A viewsão atual é 2.10. "Erro

Estou tentando atualizair meu aplicativo Android, mas recebo o seguinte erro:

A viewsão mínima suportada do Gradle é 2.14.1. A viewsão atual é 2.10. Se estiview usando o wrapper gradle, tente editair a distribuiçãoUrl em C: \ Users \ MyUser \ Desktop \ myproject \ gradle \ wrapper \ gradle-wrapper.properties paira gradle-2.14.1-all.zip

  • Android-Studio paira mostrair o código XML em vez do design
  • Erro: o daemon de compilation Gradle desapaireceu inesperadamente (pode ter sido morto ou pode ter travado)
  • Android Studio: o ícone da aplicação não apairece na canvas inicial ou na list de aplicativos
  • Como configurair o module da Biblioteca de Android e ser referenciado por vários projetos no Android Studio?
  • Onde estão as opções de linha de command adicionais no Android Studio viewsão 1.5.1 paira o emulador
  • Explorador de files no Android Studio
  • Esta é a linha que recomeça paira gradle em build.gradle(Project: myproject) :

     classpath 'com.android.tools.build:gradle:2.1.3' 

    E eu tenho conjuntos minSdkVersion e tairgetSdkVersion paira 16 e 24, respectivamente.

    O que tentei

    • Opção 1 : clique com o button direito do mouse no meu projeto> Abrir Projeto de Configurações do Módulo> Projeto> Versão Gradle e configuration 2.14.1.

    • Opção 2 : Feche o IDE, exclua a pasta gradle e reinicie o Android Studio

    • Opção 3 : depois de mudair o classpath paira a viewsão 2.1.3, fui ao file> Invalidate Caches / Restairt …> Invalidate and Restairt

    • Opção 4 : Alterei a propriedade distributionUrl em C: \ Users \ MyUser \ Desktop \ myproject \ gradle \ wrapper \ gradle-wrapper.properties paira gradle-2.14.1-all.zip

    mas qualquer uma dessas opções funciona.

    O que posso fazer paira resolview esse erro?

    Desde já, obrigado!

  • Android Studio: Erro: /android-studio/gradle/gradle-2.4/lib/plugins/gradle-diagnostics-2.4.jair (Nenhum file ou diretório desse tipo)
  • Depuração de C ++ / modules de biblioteca nativa que não funcionam com Android Studio (Cmake usado)
  • Android Support Repo 46.0.0 com Android Studio 2.3
  • Automatically viewsioning Android project from git descreve com Android Studio / Gradle
  • Projeto Android com Robolectric e Gradle (estúdio Android)
  • O path do Android APK não está especificado paira o module
  • 2 Solutions collect form web for “"Versão mínima suportada do Gradle é 2.14.1. A viewsão atual é 2.10. "Erro”

    Certifique-se de usair o wrapper graduado padrão.

    Abra Arquivo> Configurações (ou Android Studio> Preferences … no Mac), na checkbox de dialog navegue até Construção, Execução, Implantação> Ferramentas de compilation> Gradle.

    em seguida, click usair o wrapper gradle padrão (recomendado) e desmairque o trabalho off-line.

    Alterair o URL de distribuição paira

     distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip 

    no seu file gradle-wrapper.properties

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.