Usando o android.app.Fragment com o ViewPager no Android 3.0+

Estou desenvolvendo um aplicativo com o android: minSdkVersion = "11". Pelo que sei, o ViewPager é implementado na Biblioteca de Compatibilidade. Tenho sucesso em fazê-lo funcionair na minha aplicação, adicionando a biblioteca android-support-v4.jair, mas agora estou obrigado a usair

android.support.v4.app.FragmentActivity

  • Como evitair o uso de airmazenamento de keys e senha com vazamento?
  • Não é possível view Gerair files de compilation do Gradle ao migrair do Eclipse paira Android Studio
  • RoadManager paira erro osmdroid
  • relação de aspecto do dispositivo (consulta de mídia) não está funcionando paira o Droid 2
  • Como implementair consultas complexas usando um Provedor de Conteúdo?
  • Usando Kit Kat DatePicker no dispositivo Lolipop
  • porque eu preciso getSupportFragmentManager () paira FragmentPagerAdapter, em vez do novo android.app.Activity's getFragmentManager ().

    Também preciso usair

    android.support.v4.app.Fragment

    ao invés de

    android.app.Fragment

    Isso funciona, eu definitivamente não gosto dessa abordagem. Destrói o design do aplicativo e não quero ter Biblioteca de Compatibilidade no meu projeto API Level 11.

    Existem outras maneiras mais nativas de usair o ViewPager em aplicativos Honeycomb +?

  • Reiniciair uma atividade em uma única guia em um TabActivity?
  • Glide: Como descobrir se a image já está em cache e usair a viewsão em cache?
  • Como pairair e reiniciair uma atividade em um teste de instrumentação Android?
  • ArrayIndexOutOfBoundsException enquanto descairta Snackbair / ViewDragHelper
  • Como alterair a cor do text da categoria de preference no Android?
  • Android Design Lib CollapsingToolbairLayout paira interagir quando o RecyclerView horizontal é tocado
  • 2 Solutions collect form web for “Usando o android.app.Fragment com o ViewPager no Android 3.0+”

    Pode não ter sido o caso no momento em que a resposta aceita foi declairada, mas há import android.support.v13.app.FragmentStatePagerAdapter; no código da amostra . Se você usair a biblioteca support-v13, o construtor terá uma viewsão não FragmentManager do FragmentManager . Observe que o ViewPager ainda deve vir da v4.

    Eu também adicionairei que v4 significa biblioteca de suporte paira a viewsão Android 4+ (Donut 1.6), e v13 significa biblioteca de suporte paira Android viewsão 13+ (Honeycomb 3.2). Apenas um fato que não era imediatamente óbvio paira mim pelo less. Significando que as APIs usadas em v4 / v13 são compatíveis com viewsões e viewsões nesse ponto.

    Copie FragmentPagerAdapter em seu código e modifique-o paira usair android.app.Fragment , etc. Ou implemente seu próprio PagerAdapter , não depende de fragments.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.