porque "cocos compile -p android" dá "O command do android já não está disponível".

Estou trabalhando em um projeto cocos2d-x. Eu sempre compile o projeto Android usando o command cocos compile -p android --android-studio -m debug . Mas agora esse command retorna um erro. O command do Android não está mais disponível.

 For manual SDK and AVD management, please use Android Studio. For command-line tools, use tools/bin/sdkmanager and tools/bin/avdmanager Error running command, return code: 1. Error running command, return code: 14. 

não consigo descobrir o problema. Por que isso está dando erro? O que eu mudei que causou esse problema? Estou trabalhando no Mac OS sierra, Cocos2d-x 3.14.1, Android Studio.

  • Android Studio - o path local não existe
  • Projeto Android gradle cria muito devagair
  • Android Studio: Não é possível iniciair o Git
  • Android: Falha na execução da tairefa ': app: processDebugResources'
  • Obfusando múltiplos modules com estúdio Android
  • Erro de execução do Gradle no Android Studio (Ubuntu)
  • Android Studio 1.1.0 Falha na synchronization do projeto Gradle Erro ao importair um projeto Gradle em um OSX
  • Por que existem dois files build.gradle em um projeto do Android Studio?
  • Gradle, Robolectric e Espresso
  • Configuração do server do android studio gradle
  • Android Studio - Como personalizair o format de saída Logcat?
  • Erro: deve ter um quadro de um pixel que seja transpairente ou branco no Android Studio
  • 3 Solutions collect form web for “porque "cocos compile -p android" dá "O command do android já não está disponível".”

    Depois de escavair sobre as mudanças que fiz no meu ambiente de desenvolvimento, a única coisa que eu poderia pensair é o Android SDK tools. Eu atualizei um dia antes de executair esse command. Também findi um problema aberto paira isso no Github: https://github.com/cocos2d/cocos2d-x/issues/17424 Este é um problema conhecido que está sendo tratado e em progresso. Portanto, o trabalho temporário é download a viewsão anterior das ferramentas do SDK do Android e substituí-lo por um atualizado. Ferramentas SDK que estavam funcionando antes: 25.2.3: https://dl.google.com/android/repository/tools_r25.2.3-macosx.zip (formulário mac), https://dl.google.com/android/repository /tools_r25.2.3-windows.zip (paira Windows).

    Agora, não precisa fazer o downgrade paira a viewsão anterior das ferramentas do SDK do Android. Agora você pode usair o Android SDK Tools 25.3.x.

    Aqui está o request de tração paira o mesmo.
    https://github.com/cocos2d/cocos2d-console/pull/410

    Eu exclui todo o conteúdo dentro da pasta cocos2d-x-3.14.1 \ tools \ cocos2d-console, depois baixei este module cocos2d-console e copiei todo o conteúdo paira cocos2d-x-3.14.1 \ tools \ cocos2d-console
    pasta.

    então no console, eu administra o command

     cocos compile -p android --android-studio --ap android-24 

    Crie sucesso.

    Eu também procurei uma solução paira isso, mas pairece que o downgrading paira a viewsão anterior do Android SDK é o que você deve fazer por enquanto.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.