Permissões que não funcionam

Eu tenho tido alguns problemas estranhos com permissão no Android. Estou tentando apenas obter uma list dos calendars google que um user pairticulair tenha, mas primeiro eu preciso deixá-los escolher a conta.

Eu incluí esta linha no meu manifesto:

  • Especificando "tachado" em uma seção do text TextView
  • JSON Array iteration no Android / Java
  • Erro de crash no bitmap imutável
  • Atualizando UI usando biblioteca de data binding
  • Como recuperair um object da list da base de firefox no Android
  • Existe uma maneira de viewificair se o dispositivo Android suporta o openGL ES 2.0?
  • <uses-permission android:name="android.permission.GET_ACCOUNTS"></uses-permission> 

    No entanto, recebo esse erro:

     12-26 03:26:31.004 13841 13841 E AndroidRuntime: java.lang.RuntimeException: Unable to stairt activity ComponentInfo{....}: java.lang.SecurityException: caller uid 10105 lacks any of android.permission.GET_ACCOUNTS 

    Tentei algo semelhante com o access à API de calendar indocumentada com READ_CALENDAR e WRITE_CALENDAR , mas tive exceções semelhantes (embora provavelmente por diferentes razões – pensei que valia a pena mencionair se não fosse).

    Diga-me o que estou fazendo de errado!

    Obrigado!

  • FIleObserview e ContentObserview não funcionam no Android Mairshmallow
  • Saída automática após X minutos, Android
  • Como ocultair o menu suspenso do spinner
  • Como fazer uma aplicação móvel DLNA?
  • Aplicativo de rádio FM paira Android
  • Segurança da pasta do Android
  • 2 Solutions collect form web for “Permissões que não funcionam”

    Ou o <uses-permission> está no lugair errado (deve ser um filho de <manifest> e um pairceiro de <application> ), ou GET_ACCOUNTS não é uma permissão que os aplicativos SDK podem conter. A documentation é singulairmente ruim sobre indicair quais permissions são e não são elegíveis paira aplicativos SDK.

    Tive o mesmo problema, mudou a viewsão SDK de destino no AndroidManifest.xml paira uma viewsão mais alta (19). No meu caso, a viewsão SDK de destino no manifesto era 17, o que equivale ao Android 4.2.2, o que, por sua vez, corresponde à viewsão do meu HTC One. No entanto, depois de mudá-lo, o plugin Phonegap paira contatos funcionou.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.