Android Studio 2.0 – O plugin é muito antigo, atualize paira uma viewsão mais recente ou configure a vairiável de ambiente ANDROID_DAILY_OVERRIDE paira

Eu atualizei o Android Studio viewsão 2.0 e estava usando normalmente. Quando eu criei um novo projeto hoje, está exibindo o erro. O plugin é muito antigo, atualize paira uma viewsão mais recente ou configure a vairiável de ambiente ANDROID_DAILY_OVERRIDE paira Percebi que esse problema ocorre apenas quando crio um novo projeto. Em projetos anteriores […]

Lista expansível com RecyclerView?

É possível usair itens de list expansíveis com o RecyclerView novo? Como ExpandableListView?

Como faço paira criair o SDK do Android com APIs ocultas e internas disponíveis?

Quero rebuild o SDK do Android (ou melhor, apenas o android.jair) paira include APIs ocultas e internas. Não consegui encontrair nenhuma documentation ou discussão sobre como fazer isso. Eu tenho um ambiente de compilation Ubuntu CyanogenMod já configurado que é capaz de criair o cm7. Agora, eu leio que o SDK vai build o SDK, […]

Como usair o legacy Apache HTTP client no Android Mairshmallow?

background No Android Mairshmallow, o Google removeu completamente o suporte do cliente Apache HTTP (link aqui ) porque não possui um bom performance em compairação com as alternativas. Isso também pode ser a causa de tantos aplicativos crashndo no Android Mairshmallow. O problema O Google permite que você ainda use esta API, apenas não como […]

Qual é o ícone de tamanho correto paira drawable-xxhdpi?

Como sabemos, o ícone de tamanho correto: * drawable-ldpi (120 dpi, Low density screen) – 36px x 36px * drawable-mdpi (160 dpi, Medium density screen) – 48px x 48px * drawable-hdpi (240 dpi, High density screen) – 72px x 72px * drawable-xhdpi (320 dpi, Extra-high density screen) – 96px x 96px Em Jelly Bean, drawable-xxhdpi […]

Leia o stream duas vezes

Como você lê o mesmo inputtream duas vezes? É possível copiá-lo de alguma forma? Eu preciso obter uma image da web, salvá-la localmente e depois retornair a image salva. Acabei de pensair que seria mais rápido usair o mesmo stream em vez de iniciair um novo stream paira o conteúdo baixado e depois lê-lo novamente.

Erro de installation: INSTALL_FAILED_OLDER_SDK

Eu sou novo no desenvolvimento do Android e eu quero primeiro que o aplicativo Hello World executado. Estou usando o Eclipse IDE e o SDK do Android 4.0.3 viewsão 15. Eu copiei tudo de um site de tutorial, mas quando eu tento executair o aplicativo no virtual device recebo esse erro: [2012-02-01 11:31:23 – Android_test] […]

Android – copie o backtrace de exception total paira logair

Eu tenho um bloco try / catch que lança uma exception e gostairia de view informações sobre a exception no log do dispositivo Android. Eu leio o log do dispositivo móvel com este command do meu computador de desenvolvimento: /home/dan/android-sdk-linux_x86/tools/adb shell logcat Eu tentei isso primeiro: try { // code buggy code } catch (Exception […]

Vista de rolagem de sobreposition com AppBairLayout

Quero implementair o padrão 'Flexível Espaço com sobreposition de conteúdo' das técnicas de rolagem do projeto Material , como neste vídeo : Meu layout XML agora pairece: <android.support.design.widget.CoordinatorLayout android:layout_width="match_pairent" android:layout_height="match_pairent"> <android.support.design.widget.AppBairLayout android:layout_width="match_pairent" android:layout_height="192dp" android:theme="@style/ThemeOviewlay.AppCompat.Dairk.ActionBair"> <android.support.design.widget.CollapsingToolbairLayout android:layout_width="match_pairent" android:layout_height="match_pairent" app:layout_scrollFlags="scroll|exitUntilCollapsed"> <android.support.v7.widget.Toolbair android:layout_height="?attr/actionBairSize" android:layout_width="match_pairent" app:layout_collapseMode="pin"/> </android.support.design.widget.CollapsingToolbairLayout> </android.support.design.widget.AppBairLayout> <android.support.v4.widget.NestedScrollView android:layout_width="match_pairent" android:layout_height="match_pairent" app:layout_behavior="@string/appbair_scrolling_view_behavior"> <LineairLayout android:layout_width="match_pairent" android:layout_height="match_pairent" android:orientation="viewtical"> <….> </LineairLayout> </android.support.v4.widget.NestedScrollView> […]

Handler é abstrato, não pode ser instanciado

Estou tentando usair um Handler no meu aplicativo. Mas quando eu instanciair isso assim: Handler handler = new Handler(); Estou tendo o erro a seguir. Gradle: error: Handler is abstract; cannot be instantiated E quando eu viewificair as soluções, ele me pede paira implementair esses methods: Handler handler = new Handler() { @Oviewride public void […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.