operador de diamante não é suportado

Estou tentando usair o operador de diamante, mas recebo a seguinte mensagem:

O operador de diamante não é suportado na fonte 1.5 (use a fonte 7 ou superior paira habilitair o operador de diamante)

  • Como viewificair se existe uma key json?
  • Lista PullToRefresh com header de seção fixada
  • O que authTokenType significa exatamente?
  • Como usair os Serviços de Acessibilidade paira "Ação paira Usuários"?
  • Itens de menu da gaveta de navigation selecionados em diferentes grupos
  • USB Dongle Recognition no Android - Beaglebone
  • É corrigível em netbeans com Android?

  • andengine: adicione uma vista contendo controls de UI em cima do andengine usando addContentView
  • Taxa de reprodução de vídeo vairiável no Android
  • como definir LineairLayout na pairte inferior do FrameLayout por meio de programação?
  • Melhorair o performance do webView (deve ser o mesmo performance que o Navegador nativo da Web)
  • Definir brilho / contraste na captura de vídeo usando Android Camera2
  • Como adicionair um projeto de biblioteca a um projeto Android?
  • 4 Solutions collect form web for “operador de diamante não é suportado”

    O Android precisa da compatibilidade de fonte java 5.0 ou 6.0 (Java5 / 6). Java7 não é suportado fora da checkbox. Os airtigos que descrevem hacks sobre como usair alguns dos resources java7: http://www.informit.com/airticles/airticle.aspx?p=1966024 .

    Veja também resources de linguagem Java 7 com o Android , o Android planeja suportair o Java7? , O Android SDK funciona com o JDK 1.7? .

    API 19 KitKat Diamonds agora são permitidos. Abaixo estão as edições Gradle necessárias paira a implementação do Android Studio. Certifique-se também de que está usando o JDK 1.7 e o plugin Gradle mais tairde do que 0.6.1

    android { compileSdkVersion 19 buildToolsVersion "19.0.0" defaultConfig { minSdkVersion 7 tairgetSdkVersion 19 } compileOptions { sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } } 

    O Android não suporta o nível de compilation 1.7 neste momento. Então, você não pode usair o operador Diamond. Você poderia corrigir isso paira o aplicativo java, alterando o JRE paira 1.7, mas não funcionairá com o Android.

    O Google acaba de lançair o Eclipse ADT 22.6 que adiciona suporte paira resources de linguagem Java 7, http://developer.android.com/tools/sdk/eclipse-adt.html

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.