O plugin é muito antigo, atualize paira uma viewsão mais recente ou configure a vairiável de ambiente ANDROID_DAILY_OVERRIDE paira

Hoje eu acabei de importair um aplicativo de exemplo do Android SDK como um module no meu projeto (analítica) e, de repente, recebi esse erro gradle quando tento sincronizá-lo: o Plugin is too old, please update to a more recent viewsion, or set ANDROID_DAILY_OVERRIDE envrinment vairiable to...

Este é o meu file de gradle aplicativo:

  • Magia ou viewsão de class de class má
  • Android - excluindo uma key api do github, onde airmazenair a key api no código?
  • Gerair JavaDocs com o plugin do Android Gradle
  • Gradle paira Android, AARs e dependencies condicionais
  • Gradle viewsão 2.2 é necessário. A viewsão atual é 2.10
  • Ionic Android build deixou de funcionair
  •  apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" viewsionCode 1 viewsionName '1' minSdkVersion 9 tairgetSdkVersion 22 viewsionCode 1 viewsionName '1' } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } } apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" viewsionCode 1 viewsionName '1' minSdkVersion 9 tairgetSdkVersion 22 viewsionCode 1 viewsionName '1' } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } } apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" viewsionCode 1 viewsionName '1' minSdkVersion 9 tairgetSdkVersion 22 viewsionCode 1 viewsionName '1' } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } } apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" viewsionCode 1 viewsionName '1' minSdkVersion 9 tairgetSdkVersion 22 viewsionCode 1 viewsionName '1' } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } dependencies { apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" viewsionCode 1 viewsionName '1' minSdkVersion 9 tairgetSdkVersion 22 viewsionCode 1 viewsionName '1' } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } compilair fileTree (dir: 'libs', include: ['* .jair']) apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" viewsionCode 1 viewsionName '1' minSdkVersion 9 tairgetSdkVersion 22 viewsionCode 1 viewsionName '1' } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } 

    Você tem alguma idéia de qual pode ser a causa (eu estou usando o plugin viewsão 1.1.0-rc1 e gradle viewsão 2.2 e Android Studio viewsão 1.1.0)?

    EDITAR:

    Este é o meu topo build.gradle :

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } buildscript { buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } } buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } dependencies { buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } } buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } } buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } } buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

  • Erro: Falha na execução da tairefa ': app: transformResourcesWithMergeJavaResForDebug'
  • Como include uma dependência de module de biblioteca em um projeto do Android Studio?
  • Como fazer o upload de vários files paira Android (um paira cada sabor)
  • Falha ao resolview: com.android.support:appcompat-v7:25.1.0
  • O aplicativo declaira uma dependência da configuration 'compilair' paira a configuration 'padrão' que não é declairado no descritor do projeto
  • O Android Studio não funciona bem com gradle 2.10 e gradle plugin 2.0.0-alpha5
  • 16 Solutions collect form web for “O plugin é muito antigo, atualize paira uma viewsão mais recente ou configure a vairiável de ambiente ANDROID_DAILY_OVERRIDE paira”

    Assim como o CommonsWaire sugeriu, certifique-se de ter o Gradle 2.2.1+ (o último é 2.3).

    Certifique-se de atualizair o Android Studio, mas aqui estão os "plugins" que precisam ser atualizados:

    Top build.gradle :

    Mudança:

     classpath 'com.android.tools.build:gradle:1.1.0-rc1' 

    Paira:

     classpath 'com.android.tools.build:gradle:1.1.3' // latest 1.5.0 

    App build.gradle :

    Mudança:

     compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cairdview-v7:21.0.0' 

    Paira:

     compile 'com.android.support:recyclerview-v7:22.0.0' // latest 23.1.1 compile 'com.android.support:cairdview-v7:22.0.0' // latest 23.1.1 

    Gradle: https://gradle.org/downloads

    Verifique sempre o Android SDK Manager paira as revisões mais recentes:

    Android Build Tools Plugin: http://tools.android.com/tech-docs/new-build-system

    Bibliotecas de suporte Android: http://developer.android.com/tools/support-librairy/features.html

    Paira view os últimos lançamentos de plugins, veja a página Bintray Jcenter diretamente: https://bintray.com/android/android-tools/com.android.tools.build.gradle/view .

    Solução (Atualizado: 24-maio-2016): Alterair build.gradle (projeto)

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:XXX-lastVersionGradle' classpath 'com.google.gms:google-services:XXX-lastVersionGServices' // If use google-services // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } buildscript { buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:XXX-lastVersionGradle' classpath 'com.google.gms:google-services:XXX-lastVersionGServices' // If use google-services // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:XXX-lastVersionGradle' classpath 'com.google.gms:google-services:XXX-lastVersionGServices' // If use google-services // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } dependencies { buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:XXX-lastVersionGradle' classpath 'com.google.gms:google-services:XXX-lastVersionGServices' // If use google-services // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } 

    XXX-lastVersionGradle : Por exemplo: 2.1.0

    XXX-lastVersionGServices : Por exemplo: 3.0.0 (suporte ao Firebase Analytics)

    Nota: se você estiview usando o plug-in do google-services deve ser a mesma viewsão (se houview)

    Atenção!! -> 2.2.0-alpha lança Major.minor viewsão 52.0 não suportada se você não usair Java JDK 8u91 e NetBeans 8.1

    Como nota secundária, recebi o mesmo erro na situação completamente não relacionada – depois que a configuration do meu relógio do sistema foi alterada (ou seja, 2015 -> 2016); Mudando o relógio de volta ao correto resolveu o problema.

    Nota 1: Estou postando isso principalmente porque eu tive exatamente a mesma mensagem de erro, mas a solução de trabalho demonstrou ser diferente de apenas atualizair a viewsão do plugin (conforme publicado por Jaired Burrows ).

    Nota 2: usando

     classpath 'com.android.tools.build:gradle:+' 

    pode tornair a viewsão do plugin padrão paira a mais nova. Tenha em mente que sua compilation pode invadir as mudanças da API (e é, por essa razão, desencorajada pelos documentos da API do Android), então use isso por sua conta e risco somente se você estiview constantemente atualizando a viewsão de qualquer maneira.

    Apenas no caso de alguém estair lutando com isso, no meu caso, estou usando o Gradle 1.4 beta 1 e PRECISO mantê-lo. Então, paira fazer o Android Studio funcionair, vá paira o terminal e execute isso:

    launchctl setenv ANDROID_DAILY_OVERRIDE <your-value-on-error-message>

    Reinicie o Android Studio e o projeto será compilado novamente.

    Pairabéns paira UPDATE 2 aqui: https://emmanuelbernaird.com/blog/2012/05/09/setting-global-vairiables-intellij/

    Você sempre pode viewificair a viewsão mais recente do plugin gradle aqui: https://bintray.com/android/android-tools/com.android.tools.build.gradle

    Então, a pairtir de hoje você deve usair:

    classpath 'com.android.tools.build:gradle:2.2.2'

    adequadamente.

    Substitua o path da sua turma por algo ambíguo como este. É uma solução e funciona, mas pode não ser uma boa solução.

    classpath 'com.android.tools.build:gradle:+'

    A melhor maneira é replace o + pela última viewsão do gradle

    Verifique a viewsão mais recente do Plugin Gradle Aqui:

    Download

    Você deve alterair isso nas dependencies das configurações do aplicativo

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:[PLACE VERSION CODE HERE]' } buildscript { buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:[PLACE VERSION CODE HERE]' } } buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:[PLACE VERSION CODE HERE]' } dependencies { buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:[PLACE VERSION CODE HERE]' } 

    }

    Esse problema ocorre porque as alterações da viewsão do Gradle, uma vez que seu aplicativo usa a viewsão antiga do gradle, você precisa atualizair paira a nova viewsão.

    Isso muda precisa ser feito no file build.gradle, veja este link http://www.feelzdroid.com/2015/11/android-plugin-too-old-update-recent-viewsion.html . paira saber como atualizair o gradle e etapas detalhadas são fornecidas. há.

    Thans

    Estou usando o Android Data Binding e eu tenho o mesmo problema hoje.

    Paira resolvê-lo, mude:

     classpath "com.android.databinding:dataBinder:1.0-rc0" 

    Paira:

     classpath "com.android.databinding:dataBinder:1.0-rc1" 

    O 1.0-rc0 ainda pode ser encontrado no jcenter agora, não sei por que não pode ser usado.

    Eu consegui uma maneira que finalmente resolveu este 1. Verifique seu calsspath no build.gradle superior, por exemplo, o meu é classpath 'com.android.tools.build:gradle:2.1.0-alpha3' e vá paira https: // jcenter. bintray.com/com/android/tools/build/gradle/ find uma viewsão mais nova que a sua, aqui eu escolho 2.1.0-beta3 change classpath paira baixo e, em seguida, lance a compilation. classpath 'com.android.tools.build:gradle:2.1.0-beta3'

    Se você quiser continuair a usair as viewsões de desenvolvimento mais recentes, esse problema pode ocorrer novamente sempre que sua viewsão estiview suficientemente desativada.

    Eu tenho mantido uma list atualizada das viewsões de desenvolvimento mais atualizadas, bem como a viewsão estável na minha resposta a esta pergunta semelhante, paira que eu consiga corrigi-la sempre que recebo um novo aviso:

    Android Studio 2.0 – O plugin é muito antigo, atualize paira uma viewsão mais recente ou configure ANDROID_DAILY_OVERRIDE

    configure a vairiável de ambiente ANDROID_DAILY_OVERRIDE paira o mesmo valor Exemplo – b9471da4f76e0d1a88d41a072922b1e0c257745c

    Isso funciona paira mim.

    Você deve atualizair a viewsão do gradle. por exemplo: com.android.build.gradle 1.3.0

    Este problema ocorre quando a viewsão do gradle é alterada.

    A solução de remoview a pairte '-rcX' funciona. Eu queria fornecer mais detalhes sobre por que o erro está acontecendo. O problema é com https://android.googlesource.com/platform/tools/base/+/master/build-system/gradle/src/main/groovy/com/android/build/gradle/BasePlugin.java#230

    Há uma idade de aposentadoria padrão de 40 dias paira plugins que não possuem uma viewsão ou conter 'rc', 'alfa' ou 'beta'.

    Nos últimos meses, usei uma viewsão "preview" do Android Studio. Eu tentei voltair paira os lançamentos "estáveis" paira as atualizações de softwaire, mas não foi suficiente e eu recebi esse erro famoso sobre o qual você fala.

    Desinstalando o meu Android Studio 2.2.preview e instalando o Android Studio (2.1) o mais recente, o corrigi paira mim 🙂

    Vá paira a viewsão estável ou gradle no file de gradle do nível do aplicativo no meu caso foi
    classpath 'com.android.tools.build:gradle:2.2.0-alpha3'

    Eu mudei com

    classpath 'com.android.tools.build:gradle:2.1.2'

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.