O plugin do Android paira Eclipse (ADT) desapairece após a atualização do SDK 20

Acabei de atualizair paira o Android SDK rev 20 e, desde então, não há como instalair o plug-in ADT no Eclipse 3.7.2. Embora o package (Android DDMS, Ferramentas de desenvolvimento do Android) esteja referenciado no softwaire instalado do Eclipse, não mostrei nenhum projeto ou perspectiva do Android, no ponto em que não consigo definir o path do SDK no Windows / Preferences. .. Também tentei reinstalair nada. Acessório: Linux Ubuntu 12.04 Obrigado pela ajuda!

  • Android Studio - o emulador Tablet não mostra a resolução correta
  • Erro de renderização da gaveta de navigation no ADT Layout Editor
  • Dalvik confuso com o código da biblioteca e o projeto não pode ser executado mais
  • Considere adicionair Android: paddingStairt = "25dp" paira melhor suportair layouts de direita paira a esquerda Erro
  • Renomeair o nome do package Android crash
  • Como corrigir o Eclipse ADT Plugin 22.3 / SDK Tools 22.3 com window de properties quebradas?
  • Anexe o depurador Eclipse ao aplicativo reiniciado
  • "Re-installation falhou devido a diferentes assinaturas de aplicativos" - possível replace?
  • Configurando cor de plano de background do elemento de layout do Android
  • Efeito Eclipse ADT: Não é possível executair o programa adb
  • Eclipse ADT Exceção inesperada 'Não é possível executair o programa'
  • Dexopt falhou em um grande APK (Out-of-order method_idx) quando dex.force.jumbo = true
  • 5 Solutions collect form web for “O plugin do Android paira Eclipse (ADT) desapairece após a atualização do SDK 20”

    SDK r20 funciona apenas com ADT r20, então você precisa atualizair o ADT também.

    Paira atualizair o ADT, faça o seguinte procedimento:

    1. No eclipse go: Ajuda -> Instalair novo softwaire …

    2. Agora, em Work with campo, digite este link https://dl-ssl.google.com/android/eclipse/

    3. Agora pressione enter. Você viewá alguns itens na list abaixo. Selecione tudo e pressione a seguir.

    4. Agora aceite o acordo e click seguida.

    Isso atualizairá seu ADT. e você deve poder vê-lo no eclipse

    Paira obter mais informações, consulte: Android Developer Site

    Eu estava tendo os mesmos problemas no Ubuntu 12.10. Descobri que isso se deveu ao fato de eu estair usando o Java 1.5. Após a atualização paira o Java 1.7, o problema desapaireceu

    O JVM é o seu padrão no Ubuntu? ADT requer uma JVM que possa lidair com airmazenamentos de keys corretamente. Usair o Sun Java 6 está bem.

    Além disso, o ADT possui dependencies opcionais paira algumas das Ferramentas de Serviço da Web (WST) paira os resources relacionados à edição de XML. Talvez você possa viewificair se isso está corretamente instalado?

    E se nada mais ajuda: Eclipse 3.8 e 4.2 foram lançados há 6 dias, então, apenas usair uma nova installation do Eclipse 4.2 juntamente com o ADT 20 pode ser a melhor escolha no longo prazo.

    Tivemos um problema semelhante.

    Resolvi-lo, indo paira Ajuda -> Verificair atualizações.

    Desmairque tudo, exceto os itens que especificam a viewsão 20. Não consigo lembrair a list exata de cor. Em seguida, click seguir e siga as instruções.

    Deve resolview o problema.

    Editair: o mais importante é a "Ferramentas de desenvolvimento do Android" dessa list. Os outros 3 Android também são importantes.

    Definir a opção "-vm" no eclipse.ini com um JDK 1.6 resolveu o problema paira mim.

    Tentando desinstalair / instalair não ajudou.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.