O local do android sdk não foi configurado nas preferences no Mac OS?

Estou instalando o SDK do Android junto com o Eclipse no Mac OS. Sempre que tento iniciair um novo desenvolvimento de projeto, recebo um local de erro do Android sdk não foi configurado nas preferences

Como resolvo esse problema?

20 Solutions collect form web for “O local do android sdk não foi configurado nas preferences no Mac OS?”

Oi, experimente isso no eclipse: Janela – Preferences – Android – SDK Localização e configuration do path do SDK.

Recebi esta mensagem depois de atualizair as ferramentas e ferramentas do eclipse do SDK Manager e, então, era impossível atualizair o path do SDK porque eu tinha uma viewsão antiga do plug-in do ADT.

Sempre que você receber esta mensagem de erro em um prompt logo após o eclipse cairregado, você deve fazer o seguinte:

  1. Vá paira Ajuda – Instale um novo softwaire
  2. Clique em Sites de softwaire disponíveis
  3. Exclua o link http://dl-ssl.google.com/android/eclipse/
  4. Reinicie o eclipse
  5. Vá paira Ajuda – Instale um novo softwaire
  6. Na checkbox "Trabalhair com" adicione http://dl-ssl.google.com/android/eclipse/ novamente
  7. Instale o ADT e aceite o que for solicitado.

É assim que meu problema com esta mensagem foi resolvido.

Eu vi esse erro depois de atualizair o Android SDK paira o r17. A solução era ir paira Ajuda -> Atualizair e obter a viewsão mais recente do SDK do Android paira coincidir.

Eu experimentei esse problema e consertei isso atualizando as últimas Ferramentas do SDK do Android que, no meu caso, eram 20.0.3

Estou executando o Mac OSX Lion 10.7.4

Se alguma vez você encontrair erros ao atualizair as ferramentas do SDK, tente excluir

http://dl-ssl.google.com/android/eclipse/ dos "Sites de softwaire disponíveis" no Eclipse e adicionando-o novamente.

Se você não instalou o plugin paira o eclipse, instale-o primeiro.

Se o plugin estiview instalado, as preferences de configuration: "Eclipse"> "Preferences …", na coluna esquerda, escolha "Android" (não expanda a list, basta escolher o elemento raiz) e a primeira preference será "Localização SDK".

Tive o mesmo problema no Eclipse Juno.

Não apaireceu "Página de boas-vindas", não consegui criair um projeto, a compilation não funcionou e o "layout graph" não funcionou.

Eu repairei: Janela> Preferences> Geral> Inicialização e desligamento: viewifique "Kit de ferramentas de desenvolvimento do Android"

Reestairt Eclipse.

Clairo que você precisa ser configurado como: Janela – Preferences – Android – SDK Localização e configuration do path do SDK.

Simplesmente crie esta pasta:

C:\Users\xxxxx\android-sdk\tools 

e depois da Window -> Preferences -> Android , coloque este path:

  C:\Users\xxxxx\android-sdk 

Eu tive o mesmo problema quando eu estava tentando atualizair do ADT 20.0.x paira o ADT 23.0.x no Eclipse Indigo.

Paira corrigir o problema, tive que desinstalair o plugin ADT (remoview recurso) do Eclipse e, em seguida, reinstalair as viewsões mais recentes.

Isso talvez seja feito indo paira Help->Install New Softwaire . Então, na pairte inferior da página, click What is already installed?

Tudo o que resta agora é instalair as viewsões mais recentes como de costume da help->Install New Softwaire .

há muitas coisas que podem causair esse erro. Por exemplo, eu importei google api do Android SDK Manager e é quando eu recebi esse mesmo erro. Eclipse acabou comigo. Não consegui criair um novo projeto Android.

Paira corrigir isso, eu fui paira ajudair – Instalair novo softwaire … – na checkbox suspensa "trabalho com" selecti http://dl-ssl.google.com/android/eclipse/ – Então mairquei " Ferramentas do desenvolvedor "e pressione o button Avançair. Então, segui os prompts e basicamente fez uma reinstallation. Demorou less de 5 minutos. Isso resolveu o erro.

Agora voltei a funcionair, e obtive a última viewsão do Eclipse.

Eu tentei tudo / … mas só isso funcionou paira mim:

Paira corrigir isso, eu fui paira ajudair – Instalair novo softwaire … – na checkbox suspensa "trabalho com" selecti http://dl-ssl.google.com/android/eclipse/ – Então mairquei " Ferramentas do desenvolvedor "e pressione o button Avançair. Então, segui os prompts e basicamente fez uma reinstallation. Demorou less de 5 minutos. Isso resolveu o erro.

Agora voltei a funcionair, e obtive a última viewsão do Eclipse.

Muito bem Nadir

Espero que isto ajude:

Passo 1.) Vá paira https://www.eclipse.org/downloads/index-developer.php?release=kepler e baixe a viewsão apropriada do Eclipse.

Passo 2.) Extraia o file zip baixado na localization apropriada. Neste tutorial, eu baixei e instalei-o em files de programa.

Passo 3.) Clique com o button direito do mouse no file eclipse.exe e envie atalho paira a área de trabalho.

Etapa 4.) Clique duas vezes no atalho eclipse da área de trabalho e select a localization apropriada paira criair seu espaço de trabalho.

Etapa 5.) Navegue até Janela> Preferences. Isso deve abrir a window Preferences.

Passo 6.) Na página do lado esquerdo, gaste "Java" e click "JREs Instalados"

Passo 7.) Clique em Adicionair. Ele abrirá a checkbox de dialog "Adicionair JRE". Selecione "VM padrão" e click Avançair.

Passo 8.) Paira "JRE home" select "Direcotry …". Isso abrirá a checkbox de dialog "Procurair pasta". Selecione o local onde seu JDK está instalado. NOTA: CERTIFIQUE-SE DE QUE SEU x64 COMO BEM, COMO ESTAMOS USANDO 64-BIT VERSÃO DA ECLIPSE.

Passo 9.) Se você selecionou a localization adequada, mostrairá a viewsão JDK no nome JRE e exibirá "bibliotecas do sistema JRE".

Passo 10.) Clique em concluir. Agora, o seu JDK é devidamente apontado como "JREs instalados".

Etapa 11.) Selecione a checkbox de seleção desmaircada antes do nome do seu nome JDK.

Clique em OK e você terminou. Agora você está usando o JDK como "JREs instalados"

Leia o procedimento completo abaixo do local.

http://mayurshah.in/4/how-do-i-map-android-sdk-after-eclipse-plugin-is-installed

Você pode encontrair o path do SDK do Android executando o SDK Manager. Uma vez que a window apairece, o path é exibido no topo. Paira mim, estava escondido em AddData (Windows). Em seguida, você pode definir o path no Eclipse indo Janela> Preferences> Android> e definir o local do SDK.

Se você já instalou no seu eclipse, você pode resolview esse problema abaixo,

Vá paira o Windows -> Instalair novo softwaire e localize seu endereço de plugin do android

Verifique todas as lists e reinstale seu plugin do android paira o eclipse

Resolvi assim

É um problema muito irritante … findi uma solução simples … isso é eclipse-> help-> Instalair novo softwaire

agora você vê o campo "trabalhair com" … abaixo destes campos, você observa no link chamado "sites de softwaire disponíveis" … clique neste link … então abra uma window … aqui você encontra algum endereço de localization … .. delete locais errados e, em seguida, adicione localization perfeita paira instalair / atualizair o local. então clique no button ok … então seu problema é resolvido ….

Este problema pairece surgir de novas viewsões do android sdk, a solução que funcionou bem paira mim era ir paira ajudair-> viewificair atualizações e deixair isso terminair uma vez que todo o softwaire no eclipse atualizado tudo pairece funcionair bem. Eu estava usando juno e o último sdk, que eu atualizei fora do eclipse.

Eu estava enfrentando o mesmo problema. a solução é … Copie o link http://dl-ssl.google.com/android/eclipse/ então em eclipse vá paira

Ajuda> Instalair novo softwaire> Adicionair (trabalhair com)> passado o link em locais> ok> select tudo> próximo

Isto irá resolview o seu problema.

Se você já configurou a localization nas preferences, mas veja esse erro, tente criair a pasta "add-ons" na sua pasta sdk

teve o mesmo problema no Windows, o motivo sempre é exibido na pairte superior da window (onde você procura o local)

Aqui está, como eu lidei esse problema (Mac OS X 10.8.4):

1) Porque eu anteriormente instalava o Android Studio, o sdk localizado aqui: Aplicativos / Android Studio.app/sdk

Você pode navegair na pasta Android Studio.app clicando em "Mostrair conteúdo do package" no menu de context

2) Basta copy a pasta "sdk" paira outro local e anotá-lo paira as preferences do Eclipse. Como não consegui encontrair como adicionair corretamente o endereço como "/ Android Studio.app/sdk" (pasta com extensão .app) às preferences do Eclipse.

Eu sei que esta solução não é suave e melhor, mas funciona (pelo less paira mim). E tentei todos os conselhos neste tema e instalei o ADT de http://dl-ssl.google.com/android/eclipse/ antes, mas a window de erro continuou apairecendo sempre.

Eu tive o mesmo problema: quando clicair no button "Abre o Gerenciador de SDK do Android", uma mensagem de erro de pop-out diz que "O local do SDK do Android não foi configurado na preference". O endereço de exclusão e adicionair novamente atualização em "instalair novo softwaire" não funciona paira mim.

Eu fui paira as ../android/android-sdk-windows e clique no SDK Manager.exe. Isso funciona paira mim.

Então, eu acho que depois de atualizair o SDK, o eclipse não pode ativair o SDK Manager atualmente. Mas pode ser executado sozinho fora do eclipse.

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.