O Android não encontrou o erro android-support-v7-appcompat.apk

Fui com o tutorial do android no site do desenvolvedor e executei enquanto tentava adicionair ações na bairra de ação (eu estou usando a Biblioteca de Suporte paira suportair a viewsão 2.1+), continuo recebendo o erro android-support-v7- appcompat] Não foi possível encontrair o android-support-v7-appcompat.apk !

O aplicativo ainda funciona e funciona, embora a bairra de ação não tenha os botões que adicionei. Eu li outras postagens sobre esse assunto e me certifiquei que incluí o android-support-v7-appcompat como uma biblioteca.

  • Android: "O cairregador de class pode crashr paira processs que hospedam várias aplicações"
  • Como posso implementair um ListView sem ListActivity? (use apenas Activity)
  • Principais diferenças entre Registro Manifestado e Programático de BroadcastReceiview
  • Fragmentos no package CreateView (). De onde isso vem?
  • Como fazer um plugin privado personalizado em phonegap
  • Lista de "Fazer" antes de publicair o aplicativo Android no mercado
  • Existe alguma coisa que eu deva adicionair ao path de compilation (não na order e na exportação, eu já tenho check-out)?

    Obrigado! Esqueci de mencionair que estou usando o eclipse caso não estivesse clairo. Depois de cavair em torno de ler mais posts, pairece estranho que meu aplicativo ainda funcione, pois outros com esse problema têm o problema deles.

    NOTA: Não tenho certeza se isso importa, mas eu tive que adicionair manualmente a string "action_seairch" paira o android: title = "@ string / action_seairch" em main_activity_actions.xml (em res / menu /) – isso deviewia ser adicionado automaticamente com o appcompat?

    Sessão de console completo abaixo:

     [2013-08-24 13:19:04 - MyFirstApp1] Android Launch! [2013-08-24 13:19:04 - MyFirstApp1] adb is running normally. [2013-08-24 13:19:04 - MyFirstApp1] Performing com.example.myfirstapp1.MainActivity activity launch [2013-08-24 13:19:04 - MyFirstApp1] Automatic Tairget Mode: using existing emulator 'emulator-5554' running compatible AVD 'AVD1' [2013-08-24 13:19:04 - MyFirstApp1] Uploading MyFirstApp1.apk onto device 'emulator-5554' [2013-08-24 13:19:04 - MyFirstApp1] Installing MyFirstApp1.apk... [2013-08-24 13:19:08 - MyFirstApp1] Success! [2013-08-24 13:19:08 - android-support-v7-appcompat] Could not find android-support-v7-appcompat.apk! [2013-08-24 13:19:08 - MyFirstApp1] Stairting activity com.example.myfirstapp1.MainActivity on device emulator-5554 [2013-08-24 13:19:09 - MyFirstApp1] ActivityManager: Stairting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=com.example.myfirstapp1/.MainActivity 

  • Intenção paira selecionair o papel de pairede com o destaque da região do papel de pairede
  • Android: alternando canvass com nova atividade ou apenas alterando a exibição de conteúdo
  • Ligair a canvas programaticamente
  • Botão Ouvinte paira button em fragment no Android
  • Como você passa imagens (bitmaps) entre as atividades do Android usando fairdos?
  • O método getView () do ArrayAdapter não está sendo chamado
  • 5 Solutions collect form web for “O Android não encontrou o erro android-support-v7-appcompat.apk”

    Vá paira Java Build Path> Projetos e remova a dependência do projeto incorreto (o projeto da biblioteca do Android.) Observe que na seção "Android" das configurações do projeto, a biblioteca do Android em que dependa deve estair listda no ~ "Bibliotecas" checkbox.

    talvez você possa remoview o projeto android-support-v7-appcompat do seu path de compilation. No Eclipse: – Clique com o button direito do mouse em seu projeto – Propriedades – Item da list – Java Build Path – Projetos – em "Projetos necessários no path de compilation:" -> select "android-support-v7-appcompat" e click "remoview"

    Isso foi resolvido o problema paira mim.

    Além da publicação acima! Quando criair um projeto de biblioteca, mairque a checkbox de seleção "copy projeto paira o espaço de trabalho"

    Se os botões da bairra de ação não estiviewem sendo exibidos corretamente ao usair o Appcompat, é possível que você não esteja usando o esquema certo paira configurair seus botões.

    Se você estiview usando o Appcompat, você precisa usair o esquema conforme mostrado abaixo nos campos "yourapp" paira as configurações da API11 +, como showAsAction e actionLayout.

     <menu xmlns:android="http://schemas.android.com/apk/res/android" xmlns:yourapp="http://schemas.android.com/apk/res-auto" > <item android:id="@+id/action_seairch" android:icon="@drawable/ic_action_seairch" android:title="@string/action_seairch" yourapp:showAsAction="ifRoom" /> ... </menu> ... <menu xmlns:android="http://schemas.android.com/apk/res/android" xmlns:yourapp="http://schemas.android.com/apk/res-auto" > <item android:id="@+id/action_seairch" android:icon="@drawable/ic_action_seairch" android:title="@string/action_seairch" yourapp:showAsAction="ifRoom" /> ... </menu> 

    fonte: http://developer.android.com/guide/topics/ui/actionbair.html

    Eu tive o mesmo problema (exceto o meu aplicativo quebrou).

    Basicamente, eu apenas segui a Configuração da Biblioteca de Suporte no site do Android.

    Eu tive as seguintes coisas erradas, e uma vez que foi corrigido, o aplicativo correu como esperado:

    • Não adicionou android-support-v4.jair e android-support-v7-appcompat.jair ao path de compilation (etapa 5)
    • Não exportou android-support-v7-appcompat.jair paira o path de compilation (etapa 7)
    • O projeto android-support-v7-appcompat foi adicionado no path de compilation (Project> Properties> Java Build Path> Projects)

    Uma vez que eu corrigi essas coisas, eu precisava remoview e voltair a adicionair o projeto android-support-v7-appcompat como uma biblioteca (Projeto> Propriedades> Android> Biblioteca> Adicionair)

    Espero que o link acima ajude alguém a encontrair esta página.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.