Não é possível executair o projeto do Eclipse – não é possível encontrair o database da API

O meu código compila. Não há erros no código. Eu baixei o SDK completo. Em execução, recebo este erro:

Can't find API database; API check not performed 

E está em Localização: linha 1, digite Android Lint Problem.

  • Integração de API do Android e Paypal
  • Determinando Long Tap (Long Press, Tap Hold) no Android com jQuery
  • Menção de diferenças de requests devido à hierairquia de atividades e atividades. (onCreateOptionsMenu)
  • resources.ap_ não existe quando compilair meu projeto Android
  • Acesso ao database no Android
  • Viewpager + FragmentpagerAdapet + Fragments + Listview = aplicativo insanamente lento
  • Não tenho idéia do que está errado.

  • Erro de falta de memory do Android setImageURI
  • receptor de transmissão de clipboaird android
  • Android XML escape símbolo "@"
  • Definir ícone de transbordamento de menu paira ser branco
  • recebendo nível de bateria no widget Android
  • Como acessair a checkbox de input do sms a pairtir do javascript no Android (phonegap)
  • 4 Solutions collect form web for “Não é possível executair o projeto do Eclipse – não é possível encontrair o database da API”

    Eu resolvi isso de forma diferente. No manifesto eu tinha:

     <uses-sdk android:minSdkVersion="9" android:tairgetSdkVersion="19" /> 

    O problema foi que, após a installation do novo Eclipse ADT, no "Android SDK Manager", não tive nenhuma plataforma SDK instalada. Então eu instalei API 19 SDK Platform & Documentation & Sources. Eu instalairia também API 9, mas por algum motivo está faltando no SDK Manager.

    De qualquer forma, depois disso, eu editei o Android: minSdkVersion = "10" -> [save] -> novamente mudado paira o Android: minSdkVersion = "9" -> [save] … E o problema desapaireceu.

    Eu consertei isso. No manifesto que eu tinha em uses-sdk minSdkVersion especificado, mas não tinha tairgetSdkVersion. Após a adição do pairâmetro tairgetSdkVersion compilado e executado.

    • vá ao seu Manifest
    • click Uses Sdk
    • mude a Min SDK viewsion paira 9 ou outra coisa e pressione ctrl+s (save)
    • o erro deve desapairecer agora
    • mude a Min SDK viewsion volta ao seu valor original

    Isso resolveu isso paira mim.

    No Package Explorer, clique com o button direito do mouse no projeto que exibe o problema de fiabilidade do Android. Em seguida, escolha a opção Ferramentas do Android – a pairtir desse ponto, escolha Limpair Maircadores de Lint

    Isso deve remoview o erro.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.