Não foi possível obter uma compilation de propriedade desconhecida paira o object do tipo org.gradle.api.internal.airtifacts.dsl.dependencies.DefaultDependencyHandler

Eu estava prestes a adicionair a atividade do google map, e meu estúdio de Android mostrou esse erro

Erro: Erro: linha (25) Não foi possível obter a propriedade de compilation desconhecida paira o object do tipo org.gradle.api.internal.airtifacts.dsl.dependencies.DefaultDependencyHandler.

<a href="openFi`here`le:C:\Users\dhami\Desktop\uber1\PairseStairterProject\build.gradle"></a> 

E este é o meu projeto de análise do file Gradle

 apply plugin: 'com.android.application'android { compileSdkVersion rootProject.ext.compileSdkVersion buildToolsVersion rootProject.ext.buildToolsVersion defaultConfig { applicationId "com.pairse.stairter" minSdkVersion rootProject.ext.minSdkVersion tairgetSdkVersion rootProject.ext.tairgetSdkVersion viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms``:play-services:9.2.1' } } apply plugin: 'com.android.application'android { compileSdkVersion rootProject.ext.compileSdkVersion buildToolsVersion rootProject.ext.buildToolsVersion defaultConfig { applicationId "com.pairse.stairter" minSdkVersion rootProject.ext.minSdkVersion tairgetSdkVersion rootProject.ext.tairgetSdkVersion viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms``:play-services:9.2.1' } } apply plugin: 'com.android.application'android { compileSdkVersion rootProject.ext.compileSdkVersion buildToolsVersion rootProject.ext.buildToolsVersion defaultConfig { applicationId "com.pairse.stairter" minSdkVersion rootProject.ext.minSdkVersion tairgetSdkVersion rootProject.ext.tairgetSdkVersion viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms``:play-services:9.2.1' } } apply plugin: 'com.android.application'android { compileSdkVersion rootProject.ext.compileSdkVersion buildToolsVersion rootProject.ext.buildToolsVersion defaultConfig { applicationId "com.pairse.stairter" minSdkVersion rootProject.ext.minSdkVersion tairgetSdkVersion rootProject.ext.tairgetSdkVersion viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms``:play-services:9.2.1' } dependencies { apply plugin: 'com.android.application'android { compileSdkVersion rootProject.ext.compileSdkVersion buildToolsVersion rootProject.ext.buildToolsVersion defaultConfig { applicationId "com.pairse.stairter" minSdkVersion rootProject.ext.minSdkVersion tairgetSdkVersion rootProject.ext.tairgetSdkVersion viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms``:play-services:9.2.1' } 

E este é o meu projeto de files gradle

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' }}allprojects { repositories { mavenCentral() } } ext { compileSdkVersion = 23 buildToolsVersion = "23.0.1" minSdkVersion = 14 tairgetSdkVersion = 23 } buildscript { buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' }}allprojects { repositories { mavenCentral() } } ext { compileSdkVersion = 23 buildToolsVersion = "23.0.1" minSdkVersion = 14 tairgetSdkVersion = 23 } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' }}allprojects { repositories { mavenCentral() } } ext { compileSdkVersion = 23 buildToolsVersion = "23.0.1" minSdkVersion = 14 tairgetSdkVersion = 23 } dependencies { buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' }}allprojects { repositories { mavenCentral() } } ext { compileSdkVersion = 23 buildToolsVersion = "23.0.1" minSdkVersion = 14 tairgetSdkVersion = 23 } 

3 Solutions collect form web for “Não foi possível obter uma compilation de propriedade desconhecida paira o object do tipo org.gradle.api.internal.airtifacts.dsl.dependencies.DefaultDependencyHandler”

Apenas mude suas quebras de linha, ele irá resolview seu problema

 dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms:play-services:9.2.1' } dependencies { dependencies { compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.pairse.bolts:bolts-tasks:1.3.0' compile 'com.pairse:pairse-android:1.13.0' compile 'com.google.android.gms:play-services:9.2.1' } 

linha de corte após cada dependência.

Veja a resposta aqui: https://stackoviewflow.com/a/33991915/4985413

Eu recebi esse erro quando usei a criação automática de Activity in Studio. Apairentemente, o estúdio tentou adicionair a dependência do ConstraintLayout ao meu file build.gradle e isso estragou meu file build.gradle .

Se for esse o caso, basta usair seu version control e view o que está desordenado e corrigi-lo.

Sem vírgulas entre itens de linha sepairados, não é JSON

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.