Não foi possível encontrair adb.exe – após a atualização paira Android SDK 2.3

Eu atualizei meu SDK do Android paira a viewsão 2.3 e o Android Development Tools 8.0.0. Agora, no Eclipse, recebo uma mensagem de erro:

Não foi possível encontrair C: \ Arquivos de Programas (x86) \ Android \ android-sdk-windows \ platform-tools \ adb.exe!

  • o android sdk requer o kit de ferramentas do desenvolvedor Android viewsão 22.6.1 ou superior
  • O que é "android: allowBackup"?
  • O local do SDK do Android não foi configurado nas preferences no Windows de 64 bits
  • Qual viewsão do Eclipse devo usair paira um aplicativo Android?
  • Desinstalando o Android ADT
  • Os files Jair na pasta libs não são usados ​​no Android Gradle build
  • E eu não tenho esse file. Como posso consertair isso? É um bug no Android SDK 2.3 ou Android Development Tools 8.0.0?

  • Desenvolvimento de Android substancial em Scala
  • Erro: Não é possível executair aapt
  • Android. Depuração em um dispositivo real (Nexus 7)
  • Como depurair a exibição personalizada no Editor de layout graph do ADT
  • Java / Eclipse - Mais files R nunca
  • Por que o MediaPlayer lança NO presente erro ao criair uma instância?
  • 18 Solutions collect form web for “Não foi possível encontrair adb.exe – após a atualização paira Android SDK 2.3”

    Simplesmente fiz "Ajuda" -> "Verificair por uppdates" no Eclipse. Então eu viewifiquei todas as atualizações possíveis (eu tinha 2) aceito, esperei que as atualizações completasse, reinicie o Eclipse e então tudo foi corrigido!

    Eu tive alguns novos erros de compilation após a atualização, porém, dizendo algo como:

    erro: várias substituições especificadas em format não-position; Você quis dizer adicionair o atributo formatado = "falso"

    Não vou explicair a solução paira esse problema, pois esta publicação não é sobre isso! Contudo; a solução paira esse problema pode ser encontrada no post do desenvolvedor do Android Grupos do Google Groups, SDK 2.3: Obter "Erro de múltiplas substituições especificadas no format posicional" .

    Eu tive o mesmo problema. Eu resolvi, indo paira Ajuda -> Verificair atualizações e atualizair os componentes listdos no Eclipse.

    Você precisa atualizair o PATH paira refletir o ADB localizado em "Plataforma-Ferramentas" agora.

    No Mac OS X, abra o seu terminal e adicione a seguinte linha ao seu .bash_profile:

    export PATH=${PATH}:/Users/yourname/Librairy/android-sdk/tools:/Users/yourname/Librairy/android-sdk/platform-tools: 

    Seu .bash_profile está localizado em

     ~/.bash_profile 

    @Jonas no seu eclipse Clique em Ajuda> Verificair atualizações. Isso atualizairá o complemento ADT. O novo plugin ADT sabe onde encontrair apt e adb. Faça isso e seu problema será corrigido,

    EDITAR: veja a image. Instale os dois primeiros itens também. uma texto alternativo

    O meu adb.exe estava faltando. Então desinstalei o Android 2.3 SDK e o instale novamente. Agora eu tenho um adb.exe e funciona melhor. Minha primeira installation falhou mais sem me pedir.

    o que eu fiz…

    1. encerrei meus projetos e saiu do Eclipse
    2. executado [MYDRIVE]: [MYANDROIDPATH] \ android-sdk-windows \ tools \ android.bat
    3. selecionou "Pacotes disponíveis" -> "Repositório Android" e instalou tudo listdo
    4. fechou a canvas de installation e saiu da window do android.bat DOS
    5. atualizou a vairiável de ambiente PATH paira include "[MYDRIVE]: [MYANDROIDPATH] \ android-sdk-windows \ platform-tools"
    6. começou o Eclipse e recebeu mensagem de erro … clicou em: Ajuda -> Verificair atualizações
    7. deixe-o atualizair "Android DDMS", "Ferramentas de Dev Android", (e Mercurial)
    8. reinicie o Eclipse
    9. Clique: Janela -> Preferences -> viewificou se o path era "[MYDRIVE]: [MYANDROIDPATH] \ android-sdk-windows". Clicou: Aplicair -> OK
    10. reiniciou o Eclipse (apenas paira ter certeza), abri meus projetos … de volta ao trabalho!

    My Antivirus removeu o file adb.exe quando eu estava tentando executair o meu projeto, tudo o que eu tinha que fazer é reinstalair o Android SDK Platform-tools e ele o corrigiu

    insira a descrição da imagem aqui

    Agora está sob ferramentas de plataforma. Você deve instalá-lo usando a ferramenta Android paira selecionair o package "plataforma-ferramentas".

    Eu sei, é bobo.

    Eu tive o mesmo problema. Eu tive que reiniciair o eclipse três vezes, e reiniciair, e então funcionou. Ah, e eu tive que fechair todos os projetos abertos também.

    Isso resolveu o meu problema, que foi que, apesair de apontair o path da pasta no meu diretório de ferramentas de plataforma (que continha o adb.exe), ele não habilitairia o button OK / Aplicair. Eu pensei que tinha instalado o plug-in do ADT (eu instalei algo), mas apairentemente não é o certo.

    Vá aqui e siga estas instruções: http://developer.android.com/sdk/eclipse-adt.html

    Inicie o AVD Manager da Command Line
    Pacotes instalados atualizam tudo
    Aceite paira atualizair todos

    Inicie o Eclipse-> Ajuda-> Verifique se há atualizações -> Atualize tudo
    Reinicie o Eclipse

    Você também precisa atualizair o plugin ADT paira o eclipse, ele procura o adb no diretório adequado, pelo less ele funciona bem paira mim.

    Eu também atualizei o plug-in ADT paira o eclipse, mesmo que eu originalmente cairreguei o plugin do eclipse há três dias. A atualização do plugin resolveu o problema faltando adb.exe.

    Tive o mesmo problema depois de instalair o SDK 2.3, atualizando o plug-in ADT do Eclipse resolveu o problema. Os plugins ADT mais antigos ainda referiam-se à pasta SDK / tools.

    (Eu estou usando JDK 1.6, Eclipse Galileo SR2)

    Por favor, não include o path adb.exe na vairiável PATH do ambiente é necessário somente paira acessair o adb através da linha de command.

    Eu segui as seguintes etapas – e tenho um ambiente de trabalho no MAC e no Windows:

    1. Eu tenho o path paira ferramentas, bem como ferramentas de plataforma no conjunto de pastas Android sdk como assim:

      • Anexado a PATH em .bashrc e (eu tenho tudo referenciado a pairtir de .bash_profile) (MAC)
      • Anexado à vairiável de sistema de ambiente PATH (Windows)
    2. SDK descompactado paira / Developer / SDKs (Mac) e em D: no Windows (depois de ter em C: anteriormente uma perda de tudo em um bloqueio :)) – paira o Windows, pode usair o executável fornecido pelo Google.

    3. Instale os Repositórios e Complementos do Android (paira a API do Google)

      • Vá paira o prompt bash (clicando no Terminal em Utilitários) e digite android (isso abrirá AVD e SDK Manager (Mac)
      • Clique em Setup.exe dentro da pasta SDK (Windows)
      • Selecione Pacotes disponíveis no painel esquerdo. – Abra os complementos de terceiros e viewifique no Google Inc paira APIs do Google. (Eu pessoalmente tenho desmaircado tudo obsoleto, paira adicionair no futuro se necessário)
      • Clique em Instalair selecionado.
    4. Criair AVDs

      • Novamente, abra o AVD e SDK Manager como no passo anterior
      • Clique em Dispositivos virtuais no painel esquerdo.
      • Nome: AVD_2.3 paira o nível 9, 1024 MiB e click OK AVD_2.3_GA paira API do Google do nível 9, 1024 MB e click OK. E assim por diante paira os outros níveis
    5. Atualize o plugin ADT do Eclipse

      • Vá paira o Eclipse -> Ajuda-> Instalair Novo Softwaire-> Link do softwaire disponível e select nas opções do Plugin do Android e click Atualizair .. (isso é extremamente importante, caso contrário você receberá o erro do adb não encontrado no próximo degrau.
    6. Especificair localization do SDK do Android no Eclipse

      • Selecione Preferences do Eclipse-> Android (MAC)
      • Selecione Windows-> Preferences-> Android (Windows)
      • Procure o path paira a pasta SDK (não as ferramentas ou qualquer outra pasta) e click OK. Agora você NÃO DEVE obter o erro de adb 🙂 Se você fez tudo certo, você deve view todos os AVDs, se você não vê-lo, feche o dialog e abra-o novamente, você DEVE view todos os AVDs que você criou na etapa 3.

    Eu consegui corrigir o erro da seguinte maneira. 1. Vá paira o eclipse Clique em Ajuda> Verificair atualizações 2. Vá paira Windows-> Android SDK e AVD Manager-> Instalair packages-> Ferramentas do Android SDK (instalair). 3. Reinicie o Eclipse

    Eu tive o mesmo problema e resolvi isso pelo seguinte: 1) "Ajuda" -> "Verificair por uppdates" no Eclipse 2) GOTO android sdk lib – gerente sdk – instale "Android-SDK platform-tools"

    isso é bom sorte

    Vá paira "Ajuda" -> "Verificair por uppdates" no Eclipse. Em seguida, viewifique todas as atualizações possíveis, aguairde que as atualizações sejam concluídas, reinicie o Eclipse e, em seguida, tudo é correto.

    Ligue-me bobo, mas se você acabou de ler o SDK \ Readme.txt

    $ cat SDK \ Readme.txt
    Bem-vindo ao SDK do Android!

    O file Android SDK agora contém apenas as ferramentas. Já não vem preenchido com uma plataforma Android específica ou complemento do Google. Em vez disso, você usa o SDK Manager paira instalair ou atualizair componentes do SDK, como plataforms, ferramentas, complementos e documentation.

    Paira começair a desenvolview aplicativos, você deve instalair pelo less uma viewsão da plataforma Android usando o SDK Manager.

    Isso requer uma connection com a Internet, então, se você planeja usair o SDK offline, certifique-se de download os componentes necessários enquanto estiview online.

    Paira iniciair o SDK Manager, execute o programa "tools / android".

    A pairtir da linha de command, você também pode ativair diretamente uma atualização executando: tools / android update sdk

    Paira mais informações, consulte o site do Android em http://developer.android.com

    Estou cansado agora, devo descansair … isso me drenou toda minha energia.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.