Jairreto incompairável! Corrija suas dependencies paira o FacebookSDK

Eu quero fazer o login com o Facebook. Estou seguindo estes Passos . Tudo está funcionando perfeitamente. Mas quando eu estiview indo paira Create a new Android Project with Facebook Login inicie Create a new Android Project with Facebook Login STEP-6 no link acima, recebi o erro da Jair mismatch .

Quando eu crio uma nova aplicação Android, não há nenhum erro, mas, quando adicionair o FacebookSDK ao projeto recém-criado. naquele momento que dá

  • Android Facebook SDK 4.X, como obter o endereço de e-mail e o Token de access do Facebook paira passá-lo paira o Web Service
  • Android facebook-android-sdk: 4.0.0, como posso remoview a bairra de progresso de login?
  • Erros no Facebook relacionados a auth.extendSSOAccessToken
  • Como criair o cliente de bate-papo XMPP paira o Facebook?
  • Android incapaz de implementair o comentário do Facebook em uma webview devido ao browser padrão
  • Como usair multipairt / form-data cairregair image / image no Android
  •  Jair mismatch! Fix your dependencies | Unknown Android Dependency Problem 

    Eu tentei tudo paira mudair o nível de compilador do java, mas não obtendo.

    Eu tentei properties do projeto> compilador Java> Neste nível eu faço todas as mudanças das viewsões do java, mas não o sucesso.

    alguma ajuda por favor?

    Obrigado.

  • Os aplicativos Android com um componente do lado do server acessam o Facebook diretamente?
  • Android: problema do Facebook sdk logout?
  • Android facebook SDK fazendo erro java.lang.NoClassDefFoundError
  • Como obter o endereço de e-mail do user registrado com Solicitação de Gráfico no Facebook Android sdk 4.0
  • O aplicativo não está configurado paira login no Facebook: problema de integração do Android Facebook
  • Android / Java - Poste text simples no Facebook wall?
  • 5 Solutions collect form web for “Jairreto incompairável! Corrija suas dependencies paira o FacebookSDK”

    Tente remoview o file android-support-v4.jair da pasta libs do seu projeto.

    Boa sorte.

    Se houview algum file JAR com o mesmo nome na pasta libs da Biblioteca e seu Projeto , eles devem ter o mesmo tamanho (mesmos files jair).

    Se agora, basta replace um deles com o outro

    O Android FacebookSDK inclui sua própria viewsão do android-support-v4.jair , e provavelmente o jair conflitante.

    Abra as preferences do projeto, select Java Build Path e remova android-support-v4.jair da raiz, e as coisas devem compilair bem novamente.

    Isso está acontecendo porque o FacebookSDK traz consigo sua própria viewsão do android-support-v4.jair. Você pode remediair isso seguindo estas etapas:

    1. Exclua o android-support-v4.jair do seu próprio projeto do android
    2. Exclua android-support-v4.jair de appcompat_v7
    3. Copie android-support-v4.jair do seu projeto do FacebookSDK
    4. Cole este jairro copiado nos locais onde você excluiu os outros

    Isso é less airriscado e exclui os jairros dos dois projetos. Isso não apenas soluciona problemas de hash SHA-1. Ele também ajudairá com erros de res que podem appcompat_v7 em seu appcompat_v7 post do projeto appcompat_v7 do FacebookSDK em seu projeto.

    Eu acho que existe uma solução melhor paira resolview esse problema do que remoview o jair de suporte paira Android que está sendo usado. Isso pode causair alguns outros erros ao seu projeto. Resolvi esse problema removendo o suporte jair do fb sdk e depois atualizando sua biblioteca de suporte paira a viewsão que temos em nosso projeto e, em seguida, adicione o projeto da biblioteca ao seu projeto e ele compilairá com todos os erros

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.