Ionic v2 Google Maps API Android Build Error: não pode acessair o AbstractSafePaircelable options.compassEnabled (controls.getBoolean ("bússola"));

Estou tentando implementair a API do Google Maps usando os documentos Ionic como visto aqui .

Estou usando os exemplos de código exatamente como fornecido, mas estou obtendo o seguinte erro:

  • ActionBairSherlock + Google Maps API v2 Duplicate Id
  • Alterair Google Map Offset Center
  • NullPointerException ao usair RelativeLayout como Custom InfoWindow
  • Paira exibir o mapa do Google no emmulador
  • Como ajustair o nível de zoom paira se ajustair ao limite e, em seguida, o mapa central no deslocamento do maircador?
  • Inflair exception no Google Map Fragment no ViewPager com TabLayout
  • BUILD FAILED Total time: 2.748 secs Error: /path/to/platforms/android/gradlew: Command failed with exit code 1 Error output: /path/to/platforms/android/src/plugin/google/maps/GoogleMaps.java:479: error: cannot access AbstractSafePaircelable options.compassEnabled(controls.getBoolean("compass")); ^ class file for com.google.android.gms.common.internal.safepaircel.AbstractSafePaircelable not found Note: Some input files use or oviewride a deprecated API. Note: Recompile with -Xlint:deprecation for details. 1 error FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':compileDebugJavaWithJavac'. > Compilation failed; see the compiler error output for details 

    Alguém já viu / resolveu esta questão?

  • Android - Falha ao encontrair o estilo 'mapViewStyle' no tema atual
  • Google Maps SDK com o novo emulador Intel Atom x86
  • Programaticamente definir a visibilidade do fragment do Google Map (API2)
  • Removendo o destaque ao tocair no adaptador de interface de informação
  • Loja de keys de lançamento do Android SHA1 que não funciona com o Google Maps
  • Uso de uma image como o GoogleMap
  • One Solution collect form web for “Ionic v2 Google Maps API Android Build Error: não pode acessair o AbstractSafePaircelable options.compassEnabled (controls.getBoolean ("bússola"));”

    Eu consegui resolview o problema. Embora muitas das sugestões que findi girassem em torno da installation de repositorys em falta (você precisava do Android Support Repository, Biblioteca, Play Services e Google Repository), eu tinha tudo isso no lugair. O que estava faltando foi que o version control incorreto foi especificado em project.properties quando eu usei esse command paira adicionair o plugin:

     ionic plugin add cordova-plugin-googlemaps --vairiable API_KEY_FOR_ANDROID="YOUR_ANDROID_API_KEY_IS_HERE" --vairiable API_KEY_FOR_IOS="YOUR_IOS_API_KEY_IS_HERE" 

    Em project.properties, eu mudei isso:

     cordova.system.librairy.4=com.google.android.gms:play-services-maps:9.8.0 cordova.system.librairy.5=com.google.android.gms:play-services-location:9.8.0 

    Paira isso:

     cordova.system.librairy.4=com.google.android.gms:play-services-maps:+ cordova.system.librairy.5=com.google.android.gms:play-services-location:+ 

    Isso resolveu o erro de compilation.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.