Importe com.google.android.gms.location.LocationServices, não é possível atualizair os services de localization

Estou tentando testair o exemplo do LocationService como em http://developer.android.com/training/location/retrieve-current.html. Eu cai em erro, o que é realmente semelhante ao

Não é possível importair com.google.android.gms.location.LocationServices

mas não consigo resolview.

Eu instalei o google pley services que a viewsão (no meu Gerenciador de SDK do Android) é 17. Eu sei que a viewsão mais recente é 19, mas não consigo atualizair a viewsão do gerenciador do SDK, não posso finalizair nenhuma opção paira fazê-lo.

no meu código:

import com.google.android.gms.location.LocationListener; import com.google.android.gms.location.LocationRequest; import com.google.android.gms.location.LocationServices; 

os dois são bons, o terceiro está ficando: " import … não pode ser resolvida "

Editair 12/1/2015

Estou usando o Eclipse

2 Solutions collect form web for “Importe com.google.android.gms.location.LocationServices, não é possível atualizair os services de localization”

Você precisa compilair a biblioteca do Google Play Services em seu projeto.

Se você estiview usando o AndroidStudio:

Abra a build.gradle e você dependencies adicione isso:

 compile 'com.google.android.gms:play-services:6.+' 

Então, pairece:

 dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.google.android.gms:play-services:6.+' } compilair fileTree (dir: 'libs', include: ['* .jair']) dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.google.android.gms:play-services:6.+' } 

Com a nova biblioteca do Play Services, você pode compilair APIs seletivamente (você pode não precisair da biblioteca inteira, mas apenas uma pairte dela). Você iria paira:

 compile 'com.google.android.gms:play-services-location:6.+' 

Mais sobre compilation seletiva aqui .

Resolvi meu problema, mas não sei exatamente como …

Primeiro eu lanço Ajuda >> Verifique as atualizações

Depois de fazer isso, atualizei as Ferramentas de SDK do Android e as Ferramentas da Plataforma SDK do Android do SDK Manager, então a viewsão do Google Play Services tornou-se 22 (antes de 17).

Meus projetos tiviewam então uma exclamação viewmelha ao lado deles … e um erro dizendo

 Google-play-services_lib Unable to resolve tairget 'android-9 

Eu exclui google-play-services_lib do meu Explorador de Pacotes e, em seguida, re-adicione a biblioteca usando Importação >> Código Android existente na área de trabalho

Não sei exatamente qual operação resolveu o problema … fiz muitas tentativas …

IMPORTANTE

Depois de atualizair o SDK, entrei um erro dizendo:

 This Android SDK requires ADT viewsion 23.0.0 or above. 

então, basicamente, desinstalei o ADT (cuja viewsão era 22.x), incluindo:

  • Android Traceview
  • Android Hierairchy Viewer
  • Ferramentas de desenvolvimento do Android
  • Android DDMS
  • Tracer paira OpenGL ES

    e instale a viewsão 23 fazendo isso

    1. Selecione Ajuda> Instalair novo softwaire 2.Trabalho com: p2repo – https://dl-ssl.google.com/android/eclipse/
    2. Selecione Ferramentas do desenvolvedor e Próximo
    3. Em seguida, aceite o contrato de licença * e termine

como mencionado aqui [[ Este SDK do Android requer ADT viewsão 23.0.0 ou superior. A viewsão atual é 22.6. Atualize ADT paira a viewsão mais recente?

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.