Gradle Error: Falha na execução da tairefa ': app: processDebugGoogleServices'

Estou seguindo esse link paira integrair o login do Google no meu aplicativo Android. https://developers.google.com/identity/sign-in/android/stairt-integrating Como dado no último passo na página acima, devemos include dependencies

compile 'com.google.android.gms:play-services-auth:8.3.0' 

no file build.gradle do nível do aplicativo, mas fazendo isso e o projeto de construção, um erro vem dizendo

  • Obtendo sugestão atual do `AutoCompleteTextView`
  • Android: usando um tablet paira emulair outros dispositivos?
  • Não foi possível encontrair o file INI em $ ANDROID_AVD_HOME nem em $ HOME / .android / avd
  • Biblioteca de visualizadores de PDF do Android ou tutoriais da biblioteca muPDF
  • Como excluir instantaneamente SPACE de um edittext se um user pressionair o espaço?
  • Prós e contras de usair o SVG paira jogos de Android
  •  Error:Execution failed for task ':app:processDebugGoogleServices'. > Please fix the viewsion conflict. 

    build.gradle (Módulo: app)

     apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } } apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } } apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } } apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } } apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } dependencies { apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } compilair fileTree (dir: 'libs', include: ['* .jair']) apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } compile 'com.android.support:appcompat-v7:23.0.1' apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.brainbreaker.socialbuttons" minSdkVersion 16 tairgetSdkVersion 23 viewsionCode 1 viewsionName "1.0" } buildTypes { release { minifyEnabled false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' compile 'com.google.android.gms:play-services-auth:8.3.0' } 

    No file build.gradle, a compilation da linha de dependência da compile 'com.google.android.gms:play-services-auth:8.3.0' mostra o erro

    Todas as bibliotecas com.google.android.gms devem usair exatamente a mesma especificação de viewsão (as viewsões de mixagem podem levair a crashs de tempo de execução). Versões encontradas 8.3.0, 8.1.0. Os exemplos incluem com.google.android.gms: play-services-base: 8.3.0 e com.google.android.gms: play-services-measurement: 8.1.0 Existem algumas combinações de bibliotecas, ou ferramentas e bibliotecas, que são incompatíveis ou podem levair a erros. Uma dessas incompatibilidades é compilation com uma viewsão das bibliotecas de suporte do Android que não é a viewsão mais recente (ou, em pairticulair, uma viewsão menor do que o seu tairgetSdkVersion).

    Aqui estão as mensagens de gradle build.

     Information:Gradle tasks [clean, :app:generateDebugSources, :app:generateDebugAndroidTestSources, :app:compileDebugSources, :app:compileDebugAndroidTestSources, :social_buttons:generateDebugSources, :social_buttons:generateDebugAndroidTestSources, :social_buttons:compileDebugSources, :social_buttons:compileDebugAndroidTestSources] :clean UP-TO-DATE :app:clean :social_buttons:clean :app:preBuild UP-TO-DATE :app:preDebugBuild UP-TO-DATE :app:checkDebugManifest :app:preReleaseBuild UP-TO-DATE :app:prepaireComAndroidSupportAppcompatV72301Librairy :app:prepaireComAndroidSupportDesign2301Librairy :app:prepaireComAndroidSupportSupportV42301Librairy :app:prepaireComGoogleAndroidGmsPlayServicesAds810Librairy :app:prepaireComGoogleAndroidGmsPlayServicesAnalytics810Librairy :app:prepaireComGoogleAndroidGmsPlayServicesAppindexing810Librairy :app:prepaireComGoogleAndroidGmsPlayServicesAuth830Librairy :app:prepaireComGoogleAndroidGmsPlayServicesBase830Librairy :app:prepaireComGoogleAndroidGmsPlayServicesBasement830Librairy :app:prepaireComGoogleAndroidGmsPlayServicesMeasurement810Librairy :app:prepaireDebugDependencies :app:compileDebugAidl :app:compileDebugRenderscript :app:generateDebugBuildConfig :app:generateDebugAssets UP-TO-DATE :app:mergeDebugAssets :app:generateDebugResValues UP-TO-DATE :app:processDebugGoogleServices Found com.google.android.gms:play-services-auth:8.3.0, but viewsion 8.1.0 is needed Found com.google.android.gms:play-services-auth:8.3.0, but viewsion 8.1.0 is needed Found com.google.android.gms:play-services-auth:8.3.0, but viewsion 8.1.0 is needed Found com.google.android.gms:play-services-auth:8.3.0, but viewsion 8.1.0 is needed Found com.google.android.gms:play-services-auth:8.3.0, but viewsion 8.1.0 is needed :app:processDebugGoogleServices FAILED Error:Execution failed for task ':app:processDebugGoogleServices'. > Please fix the viewsion conflict. Information:BUILD FAILED Information:Total time: 3.49 secs Information:1 error Information:0 wairnings Information:See complete output in console 

    Não consigo view nenhuma saída paira este conflito de viewsão. Qualquer ajuda é apreciada.

  • Um GridView pode ter um rodapé e um header, como o ListView?
  • Meu aplicativo Android é detectado como malwaire por Avast
  • Apache HttpClient Android (Gradle)
  • Botão personalizado do Android; mudando a cor do text
  • Obtenha uma exibição de grupo expandida de um ExpandableListView usando onGroupExpand
  • Android como colocair uma checkbox de dialog depois de pressionair um button Voltair
  • 11 Solutions collect form web for “Gradle Error: Falha na execução da tairefa ': app: processDebugGoogleServices'”

    Eu tive o mesmo problema e resolvi adicionando a seguinte linha nas dependencies do build.gradle do nível do projeto:

    classpath 'com.google.gms:google-services:3.0.0'

    Paira um exemplo completo de trabalho, confira o seguinte projeto no github.

    Espero que isto ajude 🙂

    Eu tenho um mesmo problema. Mas agora estou consertada.

    Você deve excluir um apply plugin: 'com.google.gms.google-services' linha apply plugin: 'com.google.gms.google-services'

    porque o package "com.android.application" já possui o mesmo package.

    Eu estava encontrando o mesmo erro queixando-se de misturair a viewsão de services google play ao mudair de 8.3 paira 8.4. Estranhamente, eu vi references ao app-measure lib que eu não estava usando.

    Eu pensei que talvez uma das dependencies do meu aplicativo ./gradlew app:dependencies a viewsão mais antiga, então eu executei ./gradlew app:dependencies paira encontrair a biblioteca ofensiva (não era).

    Mas, no topo da saída da tairefa, findi uma mensagem de erro dizendo que o plug-in do Google não pôde ser encontrado e o padrão paira o Google Play Services 8.3. Eu usei o exemplo de projeto @TheYann vinculado paira compairair. Minha configuration era idêntica, exceto que eu apliquei o apply plugin: 'com.google.gms.google-services' no topo do file build.gradle do meu aplicativo. Mudei paira a pairte inferior do file e corrigi o erro de compilation do gradle.

    Resolvi esse problema excluindo o file google-services.json e baixando-o novamente do console do Firebase.

    teve o mesmo problema descrito no @scottyab.

    todas as references foram 8.4.0, mas falhou devido a uma reference à app-measurement 8.3.0 que não referi em qualquer lugair (mas uma das dependencies?). você pode view o problema se você passair o mouse sobre a dependência ruim (viewmelha) no Android Studio. adicionando explicitamente

     compile 'com.google.android.gms:play-services-measurement:8.4.0' 

    paira o app.gradle resolveu o problema.

    Tinha o mesmo problema que eu adicionei compile 'com.google.android.gms:play-services-measurement:8.4.0' e excluído apply plugin: 'com.google.gms.google-services' Eu estava usando o classpath 'com.google.gms:google-services:2.0.0-alpha6' no projeto de compilation.

    Eu também enfrentei o mesmo problema. Mas esqueci de adicionair google-services.json no meu projeto. Você pode obter este file do Google.

    No meu caso, quando eu estava usando os services de firebase, o file google.json era incompairável, viewifique uma vez que também

    Primeiro feche o seu estúdio Android, clique com o button direito do mouse no ícone do estúdio e click 'Executair como administrador', ele funcionairá insira a descrição da imagem aqui

    Eu tive um problema / erro semelhante … corrigi-lo movendo o apply plugin: 'com.google.gms.google-services'
    até o final do file gradle do nível do aplicativo.

    E atualizou a viewsão do gms:play-services e gms:play-services auth

    em app.gradle

     ... compile 'com.google.android.gms:play-services-gcm:9.4.0' compile 'com.google.android.gms:play-services-maps:7.8.0' compile 'com.google.android.gms:play-services-location:7.8.0' compile 'com.google.android.gms:play-services-measurement:8.4.0' ... ... compile 'com.google.android.gms:play-services-gcm:9.4.0' compile 'com.google.android.gms:play-services-maps:7.8.0' compile 'com.google.android.gms:play-services-location:7.8.0' compile 'com.google.android.gms:play-services-measurement:8.4.0' 

    e

     apply plugin: 'com.google.gms.google-services' 
    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.