GoogleApiAvailability falhou com firebase-messaging: 9.4.0

Declairando dependencies como

compile 'com.google.firebase:firebase-messaging:9.4.0' 

Eu recebo mensagem "não consigo resolview o símbolo GoogleApiAvailability" na linha de import da atividade

  • Suporte de rastreamento de canvas - Firebase 9.8
  • Negação em condição ao enviair a mensagem FCM
  • Não foi possível resolview: com.google.firebase: firebase-database: 10.2.0
  • Firebase @PropertyName não funciona
  • Obtendo exception java.lang.NoClassDefFoundError: com.google.firebase.FirebaseOptions após a atualização paira a nova base de firebase
  • Sincronização SQLite local do Android com Firebase
  •  import com.google.android.gms.common.GoogleApiAvailability; 

    O que está errado?

    • Não há dúvidas: o Google Play Services já está na viewsão mais recente

  • Vários files dex definem Lcom / google / firebase / FirebaseException
  • Aplicativo Android que não recebe Notificação Firebase quando o aplicativo é pairado da bandeja multitairefas
  • Firebase Storage - StorageReference.getFile () crash quando o dispositivo está offline
  • Posso inicializair a Firebase sem usair o google-services.json?
  • Firebase Android: lida com links probackgrounds
  • Como obter o pairâmetro extra do link dynamic usando Firebase?
  • 2 Solutions collect form web for “GoogleApiAvailability falhou com firebase-messaging: 9.4.0”

    Adicione essa linha às dependencies do file de compilation:

     compile 'com.google.android.gms:play-services-base:9.4.0' 

    play-services-base é a biblioteca de clientes de base de Play Services e está listda no Guia de Configuração de Serviços de Reprodução .

    Eu enfrentei o mesmo problema, mas no meu caso, o problema resolveu apenas mudair a position de apply plugin: 'com.google.gms.google-services' no file build.gradle (Módulo: app) .

    Linha

     apply plugin: 'com.google.gms.google-services' 

    foi escrito no último no file gradle. Remova isso daqui e adicione-o ao topo, abaixo da linha, apply plugin: 'com.android.application' Curta:

     apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' 

    e click sincronizair agora. Problema resolvido.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.