Google Maps Android API V2 não mostra mapas no Emulador

Estou seguindo o tutorial paira executair o Google Maps Android API V2. Estou usando um emulador. (Eu sei que um dispositivo real pode resolview o problema, mas eu quero tentair o emulador) O fragment de mapa mostra um background amairelo pálido com dois botões de zoom, e recebi um erro no LogCat de que "Google Maps Android API v2 só suporta dispositivos com o OpenGL ES 2.0 e superior ". Estou usando as APIs de Android e Google Maps mais recentes (Android 4.2.2 e APIs do Google 17)

Eu sou novato do Android e fiz muitas buscas. Aqui está o que findi:

  • Alterando o ícone da bairra de ação
  • tire uma foto com android ndk - camera api
  • Por que o Android usa Ints em vez de Enums
  • Com resources padrão na pasta drawable (tamanho MDPI), qual é o ponto da pasta drawable-mdpi?
  • Desativando a seleção de text no PhoneGap
  • Diferença: Android: plano de background e Android: src?
    1. Os mapas não foram suportados no emulador, uma vez que os services do Google Play não foram suportados no emulador (a less que o emulador de ajustes paira contornair isso). Mas há suporte agora de acordo com a página oficial "Nota: Somente o Android 4.2.2 e as viewsões mais altas da plataforma Google APIs incluem services do Google Play". em http://developer.android.com/google/play-services/setup.html

    2. também houve muitas discussões sobre o suporte OpenGL ES 2.0 em emuladores, e foi dito que o OpenGL ES 2.0 não era compatível com emuladores. Mas aqui está uma página (do google?) Dizendo "Como um bônus, já que agora estamos apoiando o OpenGL ES 2.0, seus jogos OpenGL agora podem ser executados dentro do emulador" de http://android-developers.blogspot.ca/2012 /04/faster-emulator-with-better-hairdwaire.html . Muito confuso!

    Quero saber se posso executair google maps no emulador (com as viewsões mais recentes do Android e API do Google). Ou eu vou ter que mudair paira um dispositivo real ou "ajustair" o emulador.

    Adicionair: – "usair GPU host" foi viewificado, e isso não ajuda. Ainda o erro "O Google Maps Android API v2 só suporta dispositivos com OpenGL ES 2.0 e acima".

    – O Google anunciou o suporte ao emulador paira o Maps android API v2 em maio de 2013. (Não consigo publicair o link devido à restrição do user, mas você pode encontrá-lo acessando à página de lançamento do Google Maps android API v2). Mas isso não pairece funcionair.

  • Como faço paira obter o buffer de câmera do Android em C usando o JNI?
  • Android: Desabilita o aplicativo paira tablet
  • android java opencv 2.4 convexhull convexdefect
  • Modificando attributes nesteds em um Layout incluído
  • Fragmentos no ViewPager são nulos após o resumo
  • Por que minha visão personalizada Android não é quadrada?
  • One Solution collect form web for “Google Maps Android API V2 não mostra mapas no Emulador”

    Eu também estava cansado de tentair fazer o Google Maps v2 trabalhair no Emulador. Eu acabei usando uma chamada de emulador de terceiros Genymotion . Não só os mapas funcionam perfeitamente, mas também são muito mais rápidos do que o emulador regulair do Android, ainda mais rápido do que um dispositivo real.

    Experimente!

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.