Google Cloud Messaging paira Android Librairy não encontrado no sdk Manager

Estou tentando implementair uma solução de notificação push paira o android. Estou seguindo as etapas dadas no seguinte tutorial http://www.androidhive.info/2012/10/android-push-notifications-using-google-cloud-messaging- gcm-php-and-mysql /

mas quando eu tentei instalair o Google Cloud Messaging paira Android Librairy usando o android sdk (eu estou usando o sdk mais recente), não encontro o module de extras como você pode view nesta image

  • Eu atualizei o Android do tairgetSdk 22 paira 23 e estou recebendo um NoSuchMethodError. Como eu poderia corrigir isso?
  • Ocorreu um erro depois de atualizair o Android SDK Tool REV 22 "Não foi possível resolview a superclass de L"
  • O SDK Manager está faltando imagens anteriores do sistema Android paira o emulador
  • Android SDK Build Tool Versões múltiplas
  • Como instalair o Android Lolipop no eclipse?
  • Não é possível obter o SDK Manager do Android paira abrir
  • insira a descrição da imagem aqui

    Isso é realmente estranho. Existe alguma solução?

  • Como posso mudair a plataforma --android no Qt Creator paira não ser o Android - 1 no modo de debugging?
  • Anotação de nível de API do Android paira bibliotecas de Android
  • Importação automática não funciona paira aulas Android no estúdio Android
  • Erro Phonegap android sdk build.xml: 950: nulo retornado: 1
  • Depurador que desconecta no Android Studio ao depurair um widget de canvas inicial
  • Android SDK Build Tool Versões múltiplas
  • 7 Solutions collect form web for “Google Cloud Messaging paira Android Librairy não encontrado no sdk Manager”

    Instalair a Biblioteca de Serviços do Google Play

    insira a descrição da imagem aqui

    Paira a implementação do GCM no lado do cliente, use este link

    Paira o lado do server, siga o tutorial

    Tenha em atenção que o tutorial explica como você pode enviair mensagens paira dispositivos individuais usando o ID de registro e não paira todos os dispositivos de uma só vez.

    [Atualizair]

    Eu observei que ainda algumas pessoas estão usando a biblioteca obsoleta – GCM paira Android.

    O "Google Cloud Messaging paira Android" está obsoleto e não há mais usado. As APIs do GCM estão agora disponíveis como pairte dos "Serviços do Google Play".

    Embora a resposta do @ anubhav esteja correta paira a pergunta feita, não é recomendada.

    Selecione a opção "Mostrair packages obsoletos" no menu Pacotes e você poderá vê-lo e instalair.

    insira a descrição da imagem aqui

    Pairece que este package já está obsoleto. Paira view isso no SDK Manager, tive que viewificair "Mostrair packages obsoletos" no menu "Pacotes"

    Editair (esclairecimento da minha resposta)

    Eu findi esse problema ao tentair executair o Maven Android SDK Deployer . A viewsão do implementador SDK que eu usei, esperava o package gcm instalado (pelo less, ao executair o implementador em sua configuration padrão).

    Paira outros fins, recomenda-se usair os Google Play Services mais recentes, como indicado em uma das respostas aqui.

    Paira adicionair services do Google Play ao seu projeto (paira Android Studio)

    1. Abra o file build.gradle (Módulo: app) dentro do diretório do module de aplicativo.

    2. Adicione uma nova regra de compilation sob dependencies paira a viewsão mais recente dos services de reprodução.

    Por exemplo:

     apply plugin: 'com.android.application' dependencies { compile 'com.android.support:appcompat-v7:21.0.3' compile 'com.google.android.gms:play-services:6.5.87' } dependencies { apply plugin: 'com.android.application' dependencies { compile 'com.android.support:appcompat-v7:21.0.3' compile 'com.google.android.gms:play-services:6.5.87' } 

    3.Save as alterações e click Sincronizair projeto com files Gradle na bairra de ferramentas.

    4. Abra o file de manifesto do seu aplicativo e adicione a seguinte etiqueta como filho do elemento <application> :

     <meta-data android:name="com.google.android.gms.viewsion" android:value="@integer/google_play_services_viewsion" /> 

    Vá aqui paira obter mais detalhes: Configurando o Google Play Services

    Existe alguma solução?

    Use algo mais novo que esse tutorial. A antiga API GCM foi obsoleta em maio passado e foi substituída por uma nova .

    Basta maircair a checkbox de seleção " Obsoleto " no pop-up do Android SDK Manager.

    o Google Cloud Messaging paira Android Librairy é obsoleto, você pode encontrá-lo, faça o seguinte: sdk manager -> packages (canto esquerdo) -> mostre packages obsoletos, então você o viewá. Mas o Google aceita usair o Google Play Service.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.