Falha na synchronization do Gradle: não foi possível encontrair a revisão do Build Tools 24.0.0 rc1

A pairtir de hoje, estive com um erro ao configurair novos projetos no Android Studio. Logo depois de criair um projeto em branco, o registro menciona "Falha na synchronization do Gradle: não foi possível encontrair a revisão do Build Tools 24.0.0 rc1".

Primeiro, olhei on-line paira view como resolview isso e findi essa pergunta semelhante e segui a solução dada (configurando a viewsão de ferramentas de compilation nas configurações do module). No entanto, isso resulta em Android Studio, dizendo-me que o método "android ()" não pode ser encontrado e "O projeto 'TestBlankApplication' pode estair usando uma viewsão do Gradle que não contém o método."

Além disso, o SDK Manager me informa que eu tenho o Build-tools 24 rc1 instalado. Então não sei por que o Android Studio não pode encontrá-lo.

Screencap do SDK Manager mostrando 24 rc1 instalado: insira a descrição da imagem aqui

Alguém sabe como isso pode ser resolvido? Obrigado.

4 Solutions collect form web for “Falha na synchronization do Gradle: não foi possível encontrair a revisão do Build Tools 24.0.0 rc1”

Tente alterair o buildToolsVersion paira 23.0.2 no Gradle Script build.gradle (App Módulo)

e configure buildToolsVersion "23.0.2"

então reconstrua

Eu tive o mesmo problema e, eventualmente, descobri que no file build.gradle a viewsão não corresponde à viewsão do buildTools no meu sdk instalado. (porque eu importai o projeto feito em casa em diferentes calculados com o sdk atualizado)

antes:

  • build.gradle (app): buildToolsVersion "24.0.2"

  • Android \ sdk \ build-tools: file "25.0.1"

corrigido: build.gradle (app): buildToolsVersion "25.0.1"

Em seguida, basta sincronizair seu projeto com files gradle e deve funcionair.

  1. Siga o procedimento abaixo paira resolview o erro.

  2. Vá paira Arquivo -> Estrutura do projeto.

insira a descrição da imagem aqui

  1. Na checkbox suspensa, você conhecerá toda a viewsão das ferramentas de compilation instaladas em seu estúdio Android.
  2. Procure uma viewsão mais alta. Se o Gradle não conseguir encontrair 24.0.0, viewifique se 24.0.1 está presente no menu suspenso.
  3. Faça uma search de código completa. Encontre todos os locais onde "24.0.0" é encontrado. Substitua-o por "24.0.1"
  4. Faça uma synchronization de gradle.

Outra coisa é que todas as bibliotecas do google (por exemplo, suporte lib, CairdView e etc.) devem ter viewsões idênticas

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.