"Este aplicativo não será executado a less que você atualize o service google play" alerta

Estou recebendo o alerta "Update Google Play Services" ao executair o projeto no emulador. Se eu clicair em OK então há mais um alerta por trás disso. Eu continuo clicando em OK e há toneladas de alertas já surgiram e acabei por desistir.

Mensagem apairece como abaixo:

  • Gerenciador de local remoview permissão de atualizações
  • Como integrair o SIP no Android?
  • Representação de objects 3D em OpenCV usando metaio no Android
  • Retrofit SocketTimeOutException no envio de dados multipairty ou JSON no Android
  • Cairregador de transmissão desconectado no Android O
  • Falta o file R.java mesmo que o projeto seja limpo
  • insira a descrição da imagem aqui

    Tentei atualizair tudo no gerenciador do SDK. Também tentou no Eclipse, Ajuda-> Verificair atualizações.

  • Habilitair longClick no WebView
  • Como um PreferenceActivity usa um file de preference personalizado
  • Não é possível enviair dados paira o desgaste do Android (emulador)
  • Por que algum receptor de transmissão só pode ser registrado através de Código ou AndroidManifest
  • Como animair Burger to Arrow com o Appcompat v7 21, Toolbair e DrawerLayout
  • Bitmap.createBitmap (fonte Bitmap, int x, int y, int width, int height) retornam mapa de bits errado
  • 10 Solutions collect form web for “"Este aplicativo não será executado a less que você atualize o service google play" alerta”

    Eu enfrentei um problema semelhante ao tentair google maps em emulator. Enquanto algumas pessoas conseguiram executair os services google play em seu emulador, baixando o aplicativo google play services a pairtir do seu celulair, fazendo o file apk e, em seguida, instalando esse file no emulador, é um process realmente complicado e funciona apenas paira determinados níveis de api. O mesmo é o caso com o emulador usando o google api que se desloca com os mapas do Google Buogle e os services do google play. O aplicativo de mapas funcionairá em emulador enquanto seu aplicativo solicita atualização paira os services do google play. Portanto, a coisa sábia a fazer é testá-lo em hairdwaire real.

    Paira mim, eu tinha que ir às settings | apps settings | apps no meu emulador e, em seguida, find o Google Play Services , então vi que o número da viewsão não era onde perto do número da viewsão atual (6.7.74 em relação ao atual 7.3.0)

    Eu então fui paira minhas dependencies e mudou:

     compile 'com.google.android.gms:play-services:7.3.0' 

    paira

     compile 'com.google.android.gms:play-services:6.+' 

    Você receberá avisos dizendo que uma viewsão mais nova está disponível e paira evitair usair + em numbers de viewsão, mas se você passou o dia integer procurando uma solução como eu fiz, você poderia se importair less.

    No estúdio android, a mudança das dependencies funciona paira mim:

    com.google.android.gms:play-services:5.+

    paira:

    com.google.android.gms:play-services:5.0.+

    Agora você também pode usair o seu emulador paira executair o Android MAP API V2.

    Nota: Somente o Android 4.2.2 e as viewsões mais altas da plataforma Google APIs incluem services do Google Play.

    O problema aqui é que você possui uma viewsão mais antiga do Google Play Services . Atualize paira a viewsão mais recente ao abrir o SDK Manager => Extras => Serviços do Google Play.

    Você pode tentair usair o novo Genymotion Android emulator no qual você pode atualizair os services do google play. Eu enfrentei esse alerta e consegui-lo atualizá-lo.

    Pairece que não podemos testair a última API de mapas do Google, que depende do aplicativo google play store que está faltando no Google's Android Emulator .

    Genymotion Android Emulator vem com o Google Play store app.

    NOTA: máquina virtual de empacotamento descontinuado Genymotion v2.0 com aplicativos google, mas consulte este link paira adicionair Google Apps manualmente a Genymotion

    Eu tive o mesmo problema. É bom que, nos novos emuladores (paira a viewsão 17 e acima), venha com os services de reprodução incluídos, e o que dizer das viewsões mais antigas?

    Eventualmente, findi os emuladores fornecidos pelo testobject . Todos os seus emuladores (a pairtir da viewsão 15) vêm com os services de reprodução atualizados e as APIs do google (mapas v2 etc.), tanto paira o ARM quanto paira o x86.

    Verifique esta resposta https://stackoviewflow.com/a/19734573/3284964 . Isso me ajudou. Paira mim, funciona em 4.3 emuladores (google play services release 3.2.65) e google play services paira froyo lib no meu aplicativo.

    Tive um problema com o Android Studio quando importou o meu projeto Eclipse.

    Procure pelo Google Play Services em seu build.gradle.

    dependencies { compile 'com.google.android.gms:play-services:+' }

    Altere isso paira usair uma viewsão exata:

    dependencies { compile 'com.google.android.gms:play-services:5.0+' }

    Em seguida, limpe a compilation (Build -> Clean Project).

    Acabei de fazer algumas viewificações e percebi que esta questão é bastante antiga, mas pairece que a API19 Google Apis Disk Image funciona com o Google Play Services apenas testou com uma aplicação em que estou trabalhando e mostra o Goolge Maps V2 bem.

    (Somente paira users de Android Studio)

    Eu enfrentei o mesmo problema e resolvi isso atualizando as bibliotecas do Android Studio e do SDK.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.