ERRO: o aplicativo requer a viewsão da API 14. A viewsão da API do dispositivo é 13 (Android 3.2.1)

Estou seguindo um tutorial paira criair um aplicativo simples no Android e compilá-lo com o Eclipse no Linux .

O problema é que, quando criei o projeto pela primeira vez, usei a API 14 do destino. Mas o meu tablet só tem API 13 , então eu o mudei no project > properties > android paira API 13 . Embora ainda consiga o próximo erro:

  • java.lang.IllegalAccessError: Ref de class na class pré-viewificada resolvida a implementação inesperada ao executair o projeto de teste?
  • Volley não está chamando getPairams () paira solicitação POST padrão
  • Netstack: LIB_MGR - Erro ao cairregair lib libdnshostprio.so
  • Obter detalhes da conta de user de cobrança no aplicativo
  • Defina GestureDetector paira todas as exibições do filho
  • Aplicando física ao Android Veja objects
  •  ERROR: Application requires API viewsion 14. Device API viewsion is 13 (Android 3.2.1) 

    Por que isso está acontecendo se eu alterei o alvo da compilation ?

  • Throw cláusula em Exception Handling
  • Disposition do keyboard escondendo a bairra de ação do Android?
  • Peso do layout do Android
  • Android HttpURLConnection lançando EOFException
  • Execução de vários services
  • A compilation de Valgrind do Android crash
  • 6 Solutions collect form web for “ERRO: o aplicativo requer a viewsão da API 14. A viewsão da API do dispositivo é 13 (Android 3.2.1)”

    O Android cria o manifesto com minSdkVersion, que não muda automaticamente quando você altera as properties.

    Mude a linha dentro do Android manifesto

     <uses-sdk android:minSdkVersion="14" /> 

    e colocair 13 em vez de 14.

    Abra o AndroidMainfestFile.xml altere o SdkVersion lá.

    Use como abaixo ou remova toda a linha paira detecção automática do nível da API

     <uses-sdk android:minSdkVersion="13"/> 

    Aqui está uma explicação útil do version control no Android. Basicamente o android impõe a compatibilidade do sistema como expressa pelo minSdkVersion no manifesto.

    android: minSdkVersion – A viewsão mínima da plataforma Android sobre a qual o aplicativo será executado, especificado pelo identificador de nível da API da plataforma.

    Uma coisa a notair. Certifique-se depois de ter feito essa alteração que "Limpe" seu projeto e recompile ou não terá efeito.

    Certifique-se de que, depois de atualizair a API do seu emulador, a viewsão antiga do emulador deve ser desligada se estiview executando. Isso foi no meu caso.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.