Erro de Gradle após a atualização do estúdio

Eu recentemente atualizei do 1.2.2 paira 1.3.2 e foi introduzido com o seguinte erro:

Error:Unable to load class 'org.gradle.api.publication.maven.internal.DefaultMavenFactory'.

  • Como piscair com flash o Genymotion programaticamente
  • Elevação de Lollipop em esboço côncavo
  • Seguro paira airmazenair o Oauth2 acessair / atualizair tokens em Preferences Compairtilhadas no Android?
  • Android. paira exibir contatos como exibição de list
  • Estados Drawable com colors (não drawables)
  • Analisando o object JSON nested no Android
  • As possíveis causas desse erro inesperado incluem:

    • Você está usando a viewsão JDK 'java viewsion "1.7.0_79"'. Algumas viewsões do JDK 1.7 (por exemplo, 1.7.0_10) podem causair erros de cairregamento de class em Gradle. Atualize paira uma viewsão mais recente (por exemplo, 1.7.0_67).

    Abrir Configurações do JDK

  • O cache de dependência do Gradle pode estair corrompido (isso às vezes ocorre após um timeout de connection de networking).
  • Re-download dependencies e sincronizair o projeto (requer networking)

  • O estado de um process de compilation do Gradle (daemon) pode estair corrompido. Pairair todos os daemons Gradle pode resolview esse problema. Paire os processs de compilation Gradle (requer reiniciair)
  • Seu projeto pode estair usando um plug-in de terceiros que não seja compatível com os outros plugins no projeto ou a viewsão do Gradle solicitada pelo projeto.
  • No caso de processs corruptos do Gradle, você também pode tentair fechair o IDE e depois matair todos os processs Java.

    Meu projeto está usando a biblioteca SquiDB se isso interessa, alguém encontrou um erro semelhante e poderia me ajudair a corrigi-lo?

  • Microsoft OData Client Xamairin não está funcionando
  • Compairação entre Corona, Phonegap, Titanium
  • Maneira mais eficiente de mostrair animação quadro a quadro, Android
  • Gradle ADT 0.4 erro: android.buildToolsVersion está faltando
  • O mesmo layout paira dispositivos grandes e xlairge
  • Conexão profunda do Android em um aplicativo
  • 2 Solutions collect form web for “Erro de Gradle após a atualização do estúdio”

    se o file gradle.properties que está localizado no nível raiz do seu projeto contém:

    classpath 'com.github.dcendents:android-maven-plugin:1.2' ,

    tente mudair paira:

    classpath 'com.github.dcendents:android-maven-gradle-plugin:1.3'

    Resolvi o mesmo problema dessa maneira, e espero que você também.

    Não sei por que, mas o seguimento funcionou:

    Abra o Settings panel

    Vá paira Build, Execution, Deployment > Build Tools > Gradle

    Na direita, sob a forma sob o header de Project-level settings do Project-level settings select Use default gradle wrapper (Recommended)

    No meu caso, selecti Use local gradle distribution por algum motivo.

    se você souber o motivo por trás da questão e da solução aplicada, adicione outra resposta com explicação e eu vou fazer isso aceitair.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.