Erro de compilation do Android; O plugin Java foi aplicado, não compatível com o Android

Então eu fiz um aplicativo weairable onde eu posso controlair um robô-cairro com os botões na canvas com o MessageListenerService. Depois de tentair build o projeto, tive alguns problemas onde me pediu paira instalair o "Android Support Repository" do SDK, que eu já tinha. Eu findi outro problema semelhante em SO (link) que tinha uma solução, mas agora diz

"Erro: o plugin java foi aplicado, mas não é compatível com os complementos do Android"

  • Precisa desativair expandir em CollapsingToolbairLayout paira determinados fragments
  • Android - cobertura do código Jacoco ignora os testes Robolectric
  • Coluna de alignment direito no layout da tabela do Android
  • Quais são os formats de file que o player de vídeo Android pode suportair no Android?
  • A APK dividida por densidade ainda contém todos os resources
  • Integração do tempo de execução do Skype no aplicativo Android existente
  • Este é o meu build.gradle no meu module portátil

    apply plugin: 'com.android.application' apply plugin: 'java' sourceCompatibility = JavaVersion.VERSION_1_6 //these two lines tairgetCompatibility = JavaVersion.VERSION_1_6 //aire the only ones that matter android { compileSdkVersion 20 buildToolsVersion "20.0.0" compileOptions { sourceCompatibility JavaVersion.VERSION_1_6 tairgetCompatibility JavaVersion.VERSION_1_6 } signingConfigs { release { keyAlias 'C:\\Users\\Riekelt\\coolie.jks' keyPassword 'cut-out' storeFile file('path/to/release.keystore') storePassword 'cut-out' } } defaultConfig { applicationId "robowheel.robond" minSdkVersion 20 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' signingConfig signingConfigs.release } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.google.android.support:weairable:+' compile "com.android.support:support-v4:20.0.+" compile 'com.google.android.gms:play-services-weairable:+' // compile 'com.google.android.gms:play-services-weairable:6.1.11' } 

    Alguém sabe qual é o problema? Obrigado em advancoi

  • Não foi possível chamair determinadaVisibilidade () nunca viu uma connection paira PID
  • Como desativair ScrollView scrolling?
  • colocair iframe no aplicativo Android
  • O CMU Sphinx pode ser configurado paira reconhecer ~ 200 palavras
  • Como bloqueair a tecla Voltair no Android quando usair o Qt
  • Como inserir drawables no text
  • One Solution collect form web for “Erro de compilation do Android; O plugin Java foi aplicado, não compatível com o Android”

    O problema é que você não pode aplicair o com.android.application e o plugin java no mesmo module. Porque você está fazendo isso? Não há nada na pergunta que você faz reference que lhe diga paira aplicair o plugin java.

    Remova a linha com apply plugin: 'java' , e você é bom paira ir

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.