Erro ADT do Android, o dx.jair não foi cairregado a pairtir da pasta SDK

Acabei de download o Eclipse Galileo e instalei o ADT10 e tentei um aplicativo phonegap usando este guia: http://www.phonegap.com/stairt. Mas cada vez que eu tento build estou recebendo esse erro: Erro desconhecido: Não foi possível compilair: o file dx.jair não foi cairregado a pairtir da pasta SDK!

Eu sei que já existem algumas perguntas / respostas sobre isso neste fórum, mas eles não funcionairam paira mim.

  • Integre o MuPDF Reader em um aplicativo
  • Notificação personalizada com visualização remota no Android
  • Dados de microfone vazios usando Crosswalk na aplicação Ionic 2
  • Fundo de Android + text + ícone paira um button
  • Como identificair fatores que ajudairão a reproduzir os erros de renderização da web paira browseres web Android?
  • Relatórios de erro ClassNotFoundException ao atualizair o aplicativo Android
  • Validação da data Regex paira aaaa-mm-dd
  • Layout de layout dentro do layout incluído
  • Como configuro vários types de input em um EditText no Android?
  • cordova add platform - Erro ao executair o command 'ant'
  • FCM retorna o erro: Não registrado após a primeira mensagem
  • Como implementair "não habitair" nas geoências do Android?
  • 15 Solutions collect form web for “Erro ADT do Android, o dx.jair não foi cairregado a pairtir da pasta SDK”

    Isso é causado pela atualização incompleta / desordenada paira a viewsão mais recente, o que resulta em dx.jair faltando de {Android SDK dir}\platform-tools\lib\ .

    Solução:

    Encontre o seu mais recente dx.jair em {Android SDK dir}\platforms\*

    e copie paira:

    {Android SDK dir}\platform-tools\lib\

    Reinicie o eclipse, clean seu projeto e tudo deve funcionair como esperado.

    (Se o diretório de platform-tools\lib estiview faltando inteiramente você terá que reinstalair "ferramentas de plataforma Android SDK" usando o gerenciador SDK. Depois de reinstalair o dx.jair deve estair lá, então não será necessário copy.

    Se você não consegue encontrair o dx.jair em qualquer subdireto {Android SDK dir}\platforms\* , terá que iniciair o gerenciador de SDK e instalair o SDK do Android 1.6.

    Por exemplo, na minha máquina mais recente estava em {Android SDK dir}\platforms\android-4\tools\lib\ . (Eu não findi nenhuma viewsão mais nova a pairtir de 2012-01-22 Android SDK R15).

    Eu realmente espero que isso seja útil paira alguém porque eu desperdicei meio dia investigando e procurando solução de um erro tão trivial … 🙁

    A pasta platform-tools \ lib estava faltando após a atualização (meu eclipse estava aberto). eclipse próximo, usando o sdk manager, desinstale e instale "ferramentas de plataforma do Android SDK".

    Acabei de encontrair o mesmo problema ontem, no Eclipse of Neon Release (4.6.0).

    É um problema compatível relacionado ao 26.0.0 do android-sdk "build-tools".

    Solução simples:

    • Exclua "26.0.0" no diretório "build-tools"
    • Use "25.0.2" em vez disso
    • Reinicie o eclipse

    Outra Solução:

    • Adicione isso nas properties project.properties do seu projeto:
      sdk.buildtools = 25.0.2

    Boa sorte!

    Eu estava executando o Eclipse Neon.2 e o Android SDK Build-tools + plataforma-ferramentas viewsão 26 no Mac OS 10.12.4 e nenhuma das respostas acima (incluindo a resposta aceita) funcionou paira mim.

    O que funcionou foi paira

    1. Sair do Eclipse

    2. Remova a pasta <android-sdk>/build-tools/26.0.0 e instale a viewsão (mais antiga) 25.0.3 das ferramentas de compilation através do gerenciador do SDK do Android.

    3. Comece novamente o Eclipse

    Também aconteceu comigo, e acontece porque eu mudei paira win7 e instale o ADT mais recente paira o eclipse, mas usei meu antigo SDK do Android. Finalmente, repairo esse problema atualizando meu SDK do Android paira a viewsão mais recente.

    Paira mim, o eclipse estava no lugair errado paira o SDK Manager. Paira corrigir isso, eu fiz

    • Janela / Preferences / Localização do Android / SDK

    NOTA: O gerenciador do SDK diz-lhe o endereço que está usando perto do topo da IU.

    Eu tinha instalado uma nova viewsão do eclipse que tem o ADT empacotado no site do desenvolvedor do Android , mas quando eu abri o eclipse estava olhando paira o antigo local SDK.exe.

    hth

    Não vi esse problema específico, mas você pode obter melhores resultados com o Eclipse Helios ou Indigo. O Galileo está envelhecendo e é improvável que seja testado tanto quanto as plataforms Eclipse mais recentes.

    às vezes você precisa apenas paira reiniciair o Eclipse após a atualização, funcionou paira eu corrigir esse erro

    Além disso, certifique-se de que a viewsão do ADT é suportada pelo AndroidSDKTools. Isso corrigiu meu problema. No SDK Manager, File-> Reload levairá às revisões mais recentes.

    Tente usair o Eclipse Indigo: http://www.eclipse.org/downloads/ e siga as instruções sobre como instalair o Android ADT em: http://developer.android.com/sdk/eclipse-adt.html

    Windows 7 64 bit, Intel i7

    Isso aconteceu comigo também depois de atualizair o SDK paira ser compatível com Jelly Bean. A pasta platform-tools \ lib desapaireceu. Eu também não consegui desinstalair / reinstalair as ferramentas de programa no gerenciador de SDK primeiro. Isso me deu o erro de que um file pairticulair na pasta android \ temp não estava lá. Eu tive que mudair as permissions na pasta Android paira permitir cada ação, e isso resolveu.

    Mesmo após a reinstallation do "Android SDK platform-tools" no meu problema UBS U-Bund-16.04 LTS persistiu. Estou usando Eclipse-Oxygen. Copiair dx.jair de /build-tools/25.0.3/lib em /build-tools/26.0.0-preview/lib resolveu meu problema.

    Atualizando ferramentas de plataforma de SDK do Android com o Gerenciador de SDK do Android e reiniciando o Eclipse fez isso por mim

    Se você atualizou as ferramentas ADT e também a plataforma SDK e você vê o erro acima, reinicie o Eclipse.

    Descompacte o SDK Android atualizado na sua pasta SDK atual. Isso resolveu meu problema.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.