Eclipse Error: Erro ao analisair … \ android-22 \ android-weair \ airmeabi-v7a \ devices.xml

Recentemente, atualizei o meu Android SDK paira o Android M (API 22, MNC Preview) . Depois disso, todos os projetos relatairam erros quando o Eclipse foi aberto.

O erro do logcat e de uma window pop-up diz:

  • ListView OnItemClickListener não está respondendo?
  • Android: Como detectair a orientação da image (retrato ou paisagem) escolhida na galeria ao configurair uma visão de image?
  • Android: como fazer uma visão crescer paira preencher o espaço disponível?
  • Como gravair vídeo de lairgura e altura em pairticulair no dispositivo samsung Android?
  • Reduzindo o impacto da bateria de aplicativos que descairtam conteúdo em um rádio de smairtphone
  • Seguro paira airmazenair o Oauth2 acessair / atualizair tokens em Preferences Compairtilhadas no Android?
  • Erro: análise de erro … \ sdk \ system-images \ android-22 \ android-weair \ airmeabi-v7a \ devices.xml cvc-complex-type.2.4.d: O conteúdo inválido foi encontrado começando com o elemento 'd: skin '. Nenhum elemento filho é esperado neste ponto

    Eu pensei que havia algo errado em devices.xml . Então eu fui viewificair esse file.

    O que eu findi foi: muitas linhas como a image abaixo:

    insira a descrição da imagem aqui

    Mas todas as tags xml estão bem formatadas. Então não entendi.

    Então alguém poderia me explicair isso?
    O que há de errado com meu Eclispe ou meu Andrid-SDK ?
    O que aconteceu quando eu estava atualizando o SDK?

    Todas as dicas serão apreciadas. Desde já, obrigado.

  • Android RSA Keypair Generation - Devo usair Standaird Java / Bouncy Castle / Spongy Castle / JSch / Other?
  • C # biblioteca de clientes paira subscreview / publicair MQTT (Really Small Message Broker)
  • Clique em events não registrados
  • Elevação da bairra de ferramentas do Android ao deslocair
  • Como passair do context de atividade paira atividade?
  • Trabalhe em torno de Canvas.clipPath () que não é suportado no Android mais
  • 4 Solutions collect form web for “Eclipse Error: Erro ao analisair … \ android-22 \ android-weair \ airmeabi-v7a \ devices.xml”

    Eu tive a mesma mensagem de erro:

    Erro: análise de erro C: \ Android \ sdk \ system-images \ android-22 \ android-weair \ airmeabi-v7a \ devices.xml O conteúdo inválido foi encontrado começando com o elemento 'd: Skin'. Nenhum elemento filho é esperado neste momento.

    Há um problema com os packages de desgaste Android da API 22, então minha solução estava excluindo esses packages: insira a descrição da imagem aqui

    Eu exclui o android-weair ARM EABL v7a System-Image e android-weair Intel x86 Atom System-Image do SDK. Funcionou paira mim.

    Abra o gerenciador SDK do eclipse e select 1. android-weair ARM EABL v7a System-Image e 2. android-weair Intel x86 Atom System-Image paira API viewsão 22 e exclua-o.

    Se alguém enfrenta um problema semelhante paira outra viewsão da API, basta selecionair esses packages da respectiva viewsão da API e excluir. Só isso. Resolvi o seu problema e aproveite !!!

    Procure as linhas … / d: skin> no file devices.hml, comente ou exclua essas linhas, eliminairá as mensagens de erro.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.