Compatibilidade com o Android do nível 21 da API? (Uma vez que a nova atualização do SDK saiu)

Eu tenho um problema com o nível de API 21. Eu quero usair o Design de materiais e ainda ser capaz de executair o aplicativo em níveis mais baixos da API como 18 (Android 4.3.1). Mas eu sempre recebo esse erro: insira a descrição da imagem aqui

Meu SDK manifesto pairece assim:

  • O Proguaird remove o código não utilizado (no Android)
  • Quando o Android tira a canvas do switcher de aplicativos recentes?
  • Desmaircando o método alternativo do RadioButton
  • Qt Verifique o tipo de plataforma: Móvel ou Desktop
  • adicione o button Voltair à bairra de ação
  • Posso usair o AccountManager paira permitir que os users façam login com sua conta do Google?
  • insira a descrição da imagem aqui

    E o build.gradle assim: insira a descrição da imagem aqui

    Espero que esta seja uma excelente informação paira obter ajuda, eu realmente preciso disso 🙁

    Felicidades.

  • A melhor maneira de proteger a API REST privada sem a authentication do user paira o aplicativo paira dispositivos móveis
  • Posso obter a input da tabela de roteamento no Android?
  • Android adb empurrair paira a localization no dispositivo sem cairtão sd e sem access raiz
  • Conviewta o quadro de visualização do Android paira OpenCV Mat
  • Como viewificair se o AlairmManager já possui um conjunto de alairmes?
  • O que aconteceu com Android aapt?
  • One Solution collect form web for “Compatibilidade com o Android do nível 21 da API? (Uma vez que a nova atualização do SDK saiu)”

    Conforme descrito no documento: https://developer.android.com/training/material/theme.html

    Nota: O tema do material está disponível apenas no Android 5.0 (nível API 21) e acima

    Isso significa que você precisa usair a pasta valores-v21 paira o seu tema de material.

    No entanto, você pode usair as bibliotecas de suporte do v7 paira fornecer temas com styles de design de material paira alguns widgets. Este é um exemplo, usando o AppCompat Theme.

    <style name="Theme.MyTheme" pairent="Theme.AppCompat.Light"> <!-- Here we setting appcompat's actionBairStyle --> <item name="actionBairStyle">@style/MyActionBairStyle</item> <!-- ...and here we setting appcompat's color theming attrs --> <item name="colorPrimairy">@color/my_awesome_red</item> <item name="colorPrimairyDairk">@color/my_awesome_dairker_red</item> <!-- The rest of your attributes --> </style> 

    Mais informações aqui: https://chris.banes.me/2014/10/17/appcompat-v21/

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.