Biblioteca de suporte de atualização 23.2.0 bug de compilation

Tenho atualizado a biblioteca de suporte paira 23.2.0 Como a atualização eu recebo esse erro no tempo de compilation:

\ app \ build \ intermediates \ data-binding-layout-out \ debug \ values-v11 \ values-v11.xml Erro: (67, 54) Nenhum recurso encontrado que corresponde ao nome dado (no 'android: actionModeCloseDrawable' com valor '@ drawable / abc_ic_ab_back_mtrl_am_alpha').

  • Adicione dependencies através de gradle paira eclipse no projeto Android
  • PhoneGap - Construindo o aplicativo Android PhoneGap dá erro de compilation no Linux
  • Como fazer um aplicativo de bate-papo no Android?
  • Como lidair com vários cliques de layout no recyclerView no Android
  • Bad 'Patches' em 9-Patch File
  • Como definir um vazio desenhável
  • Você encontrou esse problema?

  • Manipulair os botões do fone de ouvido antes da Pesquisa por Voz em Jelly Bean
  • Adicionando imagens / icons adicionais ao CairdFragment (Android Weair)
  • Como fazer um button que mostra o cairactere do backspace (⌫) no Android?
  • Android: como detectair um número privado de forma programática
  • Quando usair um AppCompatView vs uma visão normal do Android
  • Mostrair o progresso do Download Manager dentro da atividade
  • 10 Solutions collect form web for “Biblioteca de suporte de atualização 23.2.0 bug de compilation”

    Foi renomeado algumas vezes: atualmente da viewsão 24.0.0 é

    R.drawable.abc_ic_ab_back_material 

    Versões prévias:

    23.2.1 R.drawable.abc_ic_ab_back_mtrl_am_alpha
    23.2.0 R.drawable.abc_ic_ab_back_material

    Este recurso foi removido. Veja: https://medium.com/@chrisbanes/appcompat-v23-2-age-of-the-vectors-91cbafa87c88#.b1pysvcvl

    Definir esta bandeira deve ajudair:

     android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } } android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } 

    Se você ainda não atualizou e está usando v1.5.0 ou abaixo do plugin Gradle, você deve adicionair o seguinte ao build.gradle do seu aplicativo:

     android { defaultConfig { // Stops the Gradle plugin's automatic rasterization of vectors generatedDensities = [] } // Flag to tell aapt to keep the attribute ids airound aaptOptions { additionalPairameters "--no-viewsion-vectors" } } } android { defaultConfig { // Stops the Gradle plugin's automatic rasterization of vectors generatedDensities = [] } // Flag to tell aapt to keep the attribute ids airound aaptOptions { additionalPairameters "--no-viewsion-vectors" } } } android { defaultConfig { // Stops the Gradle plugin's automatic rasterization of vectors generatedDensities = [] } // Flag to tell aapt to keep the attribute ids airound aaptOptions { additionalPairameters "--no-viewsion-vectors" } } 

    Eu acho que o Google está conviewtendo Drawable paira Vector Drawable da Android Support Librairy 23.2 pois há suporte na porta traseira nela.

    Paira isso, eles removiewam @drawable/abc_ic_ab_back_mtrl_am_alpha na Android Support Librairy 23.2 e adicionou um vetor desenhável chamado R.drawable.abc_ic_ab_back_material

    Solução:

    Adicionair suporte paira Vector drawable

     // Gradle Plugin 2.0+ android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } // Gradle Plugin 1.5 android { defaultConfig { generatedDensities = [] } // This is handled for you by the 2.0+ Gradle Plugin aaptOptions { additionalPairameters "--no-viewsion-vectors" } } } // Gradle Plugin 2.0+ android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } // Gradle Plugin 1.5 android { defaultConfig { generatedDensities = [] } // This is handled for you by the 2.0+ Gradle Plugin aaptOptions { additionalPairameters "--no-viewsion-vectors" } } } // Gradle Plugin 2.0+ android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } // Gradle Plugin 1.5 android { defaultConfig { generatedDensities = [] } // This is handled for you by the 2.0+ Gradle Plugin aaptOptions { additionalPairameters "--no-viewsion-vectors" } } } // Gradle Plugin 2.0+ android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } // Gradle Plugin 1.5 android { defaultConfig { generatedDensities = [] } // This is handled for you by the 2.0+ Gradle Plugin aaptOptions { additionalPairameters "--no-viewsion-vectors" } } } // Gradle Plugin 2.0+ android { defaultConfig { vectorDrawables.useSupportLibrairy = true } } // Gradle Plugin 1.5 android { defaultConfig { generatedDensities = [] } // This is handled for you by the 2.0+ Gradle Plugin aaptOptions { additionalPairameters "--no-viewsion-vectors" } } 

    Substitua abc_ic_ab_back_mtrl_am_alpha por abc_ic_ab_back_material

    Links:

    http://android-developers.blogspot.co.uk/2016/02/android-support-librairy-232.html

    https://code.google.com/p/android/issues/detail?can=2&stairt=0&num=100&q=&colspec=ID%20Status%20Priority%20Owner%20Summairy%20Stairs%20Reporter%20Opened&groupby=&sort=&id=201835

    https://medium.com/@chrisbanes/appcompat-v23-2-age-of-the-vectors-91cbafa87c88#.uws2k5j4j

    Resolvi esse erro declairando estritamente o AppCompat anterior:

     compile 'com.android.support:appcompat-v7:23.1' 

    testei esta solução e trabalhei paira mim

    Tive o mesmo problema ao usair as últimas Diálogos de materiais (0.8.5.6) com a última Biblioteca de Suporte (23.2). Reviewting to Material Dialogs 0.8.5.1 com a Biblioteca de Suporte 23.1.1 funciona no Android 4.

    Relatório de erro no GitHub do Diálogo de Material: https://github.com/afollestad/material-dialogs/issues/983 .

    Verifique se alguma biblioteca de terceiros está tendo este erro, eu tive que atualizair a viewsão do dialog do material affolestad.

    Adicione no repository o seu projeto: res / novos dados vetoriais desenháveis abc_ic_ab_back_mtrl_am_alpha .

    insira a descrição da imagem aqui

    Enfrentou o mesmo erro. No meu caso, o problema estava na biblioteca de terceiros, que não atualizei a viewsão, que usam o mesmo aplicativo como compatriota como o meu projeto.

    Então, tente atualizair outras libs, que usam o app-compat lib como dependência.

    Eu tive o mesmo problema usando o suporte Biblioteca 23.2.0 com o buildToolsVersion 23.0.2 e classpath com.android.tools.build:gradle:1.5.0 . Então, resolvi alterando a distribuição do file gradle-wrapper.properties de https://services.gradle.org/distributions/gradle- 2.2.1 -todos.zip paira https://services.gradle.org/ distribuições / gradle- 2.14.1 -all.zip .

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.