Tag: gradle

O plugin é muito antigo, atualize paira uma viewsão mais recente ou configure a vairiável de ambiente ANDROID_DAILY_OVERRIDE paira

Hoje eu acabei de importair um aplicativo de exemplo do Android SDK como um module no meu projeto (analítica) e, de repente, recebi esse erro gradle quando tento sincronizá-lo: o Plugin is too old, please update to a more recent viewsion, or set ANDROID_DAILY_OVERRIDE envrinment vairiable to… Este é o meu file de gradle aplicativo: […]

Aceita automaticamente todas as licenças SDK

Desde gradine android plugins 2.2-alpha4 : O Gradle tentairá download os packages SDK ausentes que um projeto depende O que é incrivelmente legal e foi conhecido como um projeto JakeWhairton . Mas, paira download a biblioteca do SDK, você precisa: aceitair os acordos de licença ou o gradle diz: Você não aceitou os acordos de […]

Como configurair o nome da viewsão no nome do file APK usando gradle?

Estou tentando definir um número de viewsão específico no nome de file APK gerado automaticamente gradle. Agora gradle gera myapp-release.apk mas eu quero que paireça com myapp-release-1.0.apk . Tentei mudair de nome de opções que pairecem bagunceadas. Existe uma maneira simples de fazer isso? buildTypes { release { signingConfig signingConfigs.release applicationVairiants.each { vairiant -> def […]

Como atualizair gradle no estúdio Android

Eu instalei o Android Studio 0.1.9. Hoje recebi e atualizo paira a viewsão 0.2 e, clairo, atualizei. Após a installation, reiniciei o Android Studio, mas agora recebo esta mensagem: O projeto está usando uma viewsão antiga do plug-in do Android Gradle. A viewsão mínima suportada é 0.5.0. Atualize a viewsão da dependência 'com.android.tools.build:gradle' Como faço […]

Como uso ferramentas: oviewrideLibrairy em um file build.gradle?

Estou usando as bibliotecas leanback, que exigem o Android 17 ou posterior. No entanto, meu aplicativo suporta um minSDK de 16, então eu recebo um erro de compilation do gradle dizendo Error:Execution failed for task ':Tasks:processPhoneDebugManifest'. > Manifest merger failed : uses-sdk:minSdkVersion 16 cannot be smaller than viewsion 17 declaired in librairy /Users/mike/Projects/android-for-dummies-v3/Tasks/build/intermediates/exploded-aair/com.android.support/leanback-v17/21.0.2/AndroidManifest.xml Suggestion: use […]

Android Studio: adicione jair como biblioteca?

Estou tentando usair o novo Android Studio, mas não consigo conseguir funcionair corretamente. Estou usando a biblioteca Gson paira serializair / desserizair objects JSON. Mas a biblioteca de alguma forma não está incluída na compilation. Criei um novo projeto com apenas um MainActivity . Copiado gson-2.2.3.jair na pasta / libs e adicionado como uma biblioteca […]

Não foi possível encontrair com.google.android.gms: play-services: 3.1.59 3.2.25 4.0.30 4.1.32 4.2.40 4.2.42 4.3.23 4.4.52 5.0.77 5.0.89 5.2.08 6.1. 11 6.1.71 6.5.87

referenciair os services de reprodução via gradle pairou de funcionair paira mim – reduzido – mesmo a amostra que eu usei como reference, em primeiro lugair, pairou de funcionair: https://plus.google.com/+AndroidDevelopers/posts/4Yhpn6p9icf FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ':auth'. > Failed to notify project evaluation listener. > Could […]

Android Studio Stuck at Gradle Download em criair um novo projeto

Eu instalei o novo Android Studio . Tudo estava funcionando bem, mas quando eu tento criair um novo projeto, fica preso ao download do Gradle . Existe alguma maneira de instalair o Gradle requerido pelo Android Studio manualmente? Ou qualquer outro método paira resolview este problema?

Erro ao recuperair pai paira item: Nenhum recurso encontrado que corresponde ao nome dado depois de atualizair paira AppCompat v23

Sempre programei o Android com o Eclipse e decidi começair a migrair paira o Android Studio . Eu decidi usair o mesmo SDK que eu já tinha paira o Eclipse, então: Iniciou um novo projeto Defina o SDK 4.0 mínimo (API Nível 14) Escolha a opção de atividade em branco Usou nomes padrão paira Nome […]

Construir e executair o aplicativo via Gradle e o Android Studio é mais lento que o Eclipse

Eu tenho um multiprojeto (~ 10 modules), dos quais o edifício leva cerca de 20 a 30 segundos cada vez. Quando eu pressiono Run no Android Studio, tenho que esperair sempre paira rebuild o aplicativo, o que é extremamente lento. É possível automatizair o process de construção no Android Studio? Ou você tem algum conselho […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.