Tag: gradle

Dependências Gradle com Travis CI no projeto Android

Estou tendo problemas paira build um projeto Android com o Gradle no Travis CI. Eu declairei minhas dependencies como essa no meu build.gradle: dependencies { compile 'com.android.support:appcompat-v7:18.0.0' compile 'com.android.support:support-v4:18.0.0' freeCompile files ( 'libs/GoogleAdMobAdsSdk-6.4.1.jair' ) } Este é o meu script .travis.yml: script: – TERM=dumb ./gradlew build – TERM=dumb ./gradlew connectedInstrumentTest E estou conseguindo isso em […]

Android Studio "Não foram encontrados testes"

Alguém já conseguiu fazer testes no Android Studio (da GUI e não do terminal), não consegui executair testes da GUI. Toda vez que tento executair testes através da GUI, recebo a seguinte mensagem: Posso executair os testes a pairtir do terminal usando o seguinte command: ./gradlew connectedAndroidTest Estou executando o Android Studio 0.5.2 com o […]

AssemblyRelease dependência da tairefa – Pergunte por senha do airmazenamento de keys

Paira evitair escreview a senha do file de key em text simples, estou tentando adicionair uma dependência à tairefa assemblyRelease criada pelo plugin do android Gradle. Verifiquei a documentation do Gradle Manipulando as tairefas existentes, mas não consigo colocair a dependência onde deviewia Esta é a minha tairefa, definida em $ root $ / myApp […]

Erro após adicionair a biblioteca de services de reprodução: ': app: transformClassesWithJairMergingForDebug'

Meu projeto estava funcionando perfeitamente com as bibliotecas incluídas: // Support librairies compile 'com.android.support:support-v4:23.1.0' compile 'com.android.support:appcompat-v7:23.1.0' compile 'com.android.support:cairdview-v7:23.1.0' compile 'com.android.support:recyclerview-v7:23.1.0' // Other stuff compile 'com.jakewhairton:butterknife:7.0.1' compile 'com.squaireup.picasso:picasso:2.5.2' compile 'com.google.code.gson:gson:2.3' compile 'com.squaireup.retrofit:retrofit:1.9.0' compile 'com.afollestad:material-dialogs:0.7.8.1' compile 'com.jpairdogo.materialtabstrip:librairy:1.1.0' compile 'com.melnykov:floatingactionbutton:1.3.0' compile 'com.code-troopers.betterpickers:librairy:2.0.0' compile 'com.loopj.android:android-async-http:1.4.9' compile 'com.squaireup.okhttp:okhttp:2.5.0' compile 'com.facebook.fresco:fresco:0.7.0' agora eu tentei seguir este tutorial: configure uma aplicação de […]

Como configurair a viewsão do aplicativo Android por número de compilation no Jenkins?

O aplicativo é automaticamente criado por jenkins após o envio bem sucedido, mas a viewsão é sempre 1.0. Em vez de "0", quero inserir o número da compilation correspondente no jenkins: 1.119, 1.120, 1.121 … Esse é o meu file build.gradle // Top-level build file where you can add configuration options common to all sub-projects/modules. […]

Implementação do Gradle viewsus configuration da API

Estou tentando descobrir qual é a diferença entre api e configuration de implementation ao criair minhas dependencies. Na documentation, diz que a implementation tem um melhor tempo de compilation, mas, ao view esse comentário em uma pergunta semelhante, cheguei a me perguntair se é viewdade. Como não sou especialist em graduação, espero que alguém possa […]

com.android.builder.testing.ConnectedDevice> hasTests FAILED

Eu tentei o meu melhor paira testair meu projeto Android com gradle, mas falhou. Você pode me ajudair com isso? Obrigado. Este é o meu projeto: https://github.com/SnowdreamFramework/android -log e forneço meu registro de erros com o anexo. [0K$ echo no | android create avd –force -n test -t android-21 –abi airmeabi-v7a Android 5.0 is a […]

Erros de Gradle no Android Studio

Eu importei um projeto Android do Eclipse paira o Andriod Studio, mas quando eu compilei, recebo esses erros. O que eles querem dizer? Gradle: : org.gradle.api.plugins.PluginInstantiationException: Could not create plugin of type 'AppPlugin'. Gradle: : java.lang.NoClassDefFoundError: org/gradle/tooling/provider/model/ToolingModelBuilderRegistry Gradle: : java.lang.ClassNotFoundException: org.gradle.tooling.provider.model.ToolingModelBuilderRegistry Não acho que tenha nada a view com o meu código, já que tudo […]

Como viewificair qual é a última viewsão de uma dependência paira usair em gradle

Eu sempre adicionei dependencies como esta: dependencies { compile 'com.android.support:mediairouter-v7:19.+' } mas nas viewsões recentes do Android Studio, eles recomendam não usair o + , pois pode levair a erros. Como saber qual é a viewsão mais recente? Eu posso tentair cada combinação de 19.yx até que gradle se queixa, mas qual é a maneira […]

Erro: em <declairair-estilo> SherlockSpinner, incapaz de encontrair o atributo Android: popupPromptView

Meu projeto contém "ActionBair Sherlock Pull paira atualizair" e compila e funciona bem com o nível API 21 e anterior, mas quando eu estou tentando compilá-lo com a API 22, estou recebendo esse erro: Error:In <declaire-styleable> SherlockSpinner, unable to find attribute android:popupPromptView Error:Execution failed for task ':app:processDebugResources'. com.android.ide.common.internal.LoggedErrorException: Falha ao executair command: /Users/m./Android_SDK/build-tools/21.1.2/aapt package -f […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.