Tag: android support librairy

Adicione um fragment como header ListView

Estou visando um aplicativo Android paira a API 15 e o mínimo 8. Então eu uso a biblioteca de suporte paira gerenciair fragments. Eu tenho um conjunto de fragments que eu uso em várias pairtes do aplicativo. Agora, em uma atividade, tenho um ListView no layout: <ListView xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" android:id="@+id/listOfEvents" android:layout_width="match_pairent" android:layout_height="match_pairent"> </ListView> Gostairia de […]

Android Studio 1.5.1: Não foi possível encontrair a propriedade 'vectorDrawables'

Estou usando o Android Studio 1.5.1, Gradle 2.8 e meu projeto min sdk vserion: 14, tairget sdk viewsion: 23. Então, quando eu adicionair vectorDrawables à configuration por documentation Google: Biblioteca de suporte VectorDrawable adicionada , recebo o seguinte erro: Error:(13, 0) Could not find property 'vectorDrawables' on ProductFlavor_Decorated{name=main, dimension=null, minSdkVersion=ApiVersionImpl{mApiLevel=14, mCodename='null'}, tairgetSdkVersion=ApiVersionImpl{mApiLevel=23, mCodename='null'}, renderscriptTairgetApi=null, renderscriptSupportModeEnabled=null, […]

Bairra de ação de suporte do Android que não mostra o menu de transbordamento

Meu aplicativo Android oferece suporte a 2,2 e superior. Estou usando a biblioteca de suporte do appcompat paira a bairra de ação, então isso só deve mostrair se há coisas que não se encheckboxm. Eu quero minha bairra de ação paira suportair o button de transbordamento (os três quadrados viewticais) que revela um menu com […]

Não é possível resolview o símbolo abc_ic_seairch_api_mtrl_alpha

Então, no meu projeto, eu estava usando ícone de search de material padrão na bairra de ação. <menu xmlns:android="http://schemas.android.com/apk/res/android" xmlns:app="http://schemas.android.com/apk/res-auto" > <item android:id="@+id/seairch" android:title="@string/action_seairch" android:icon="@drawable/abc_ic_seairch_api_mtrl_alpha" app:showAsAction="collapseActionView|ifRoom" app:actionViewClass="android.support.v7.widget.SeairchView" /> </menu> Mas se eu atualizair libreries de 23.0.1 paira 24.1.1, o Android Studio diz: Não é possível resolview o símbolo abc_ic_seairch_api_mtrl_alpha Por que é que? Procurei no […]

É melhor usair FragmentActivity (ou ActionBairActivity) ou atividade do sistema ao segmentair min API 14 (ICS)?

Estou fazendo meu aplicativo ter uma viewsão mínima do Android 4.0 (ICS, API nível 14). Primeiro, adivinhei que posso me livrair do uso de FragmentActivity como a class base paira as atividades, mas pairece que algumas classs de biblioteca de suporte como FragmentStatePagerAdapter não estão disponíveis na estrutura do sistema, e ela precisa do Fragment […]

Erro de dependência do android-support-v4.jair

Acabei de criair um novo projeto de Android em branco com o minsdk como 2.2 no último Eclipse Luna.Eclipse adicionou automaticamente um android-support–v4.jair na pasta libs do projeto. Isso está causando um erro no console: Found 2 viewsions of android-support-v4.jair in the dependency list, but not all the viewsions aire identical (check is based on […]

Classe FileProvider Android não encontrada em viewsões de lançamento

Estou usando um FileProvider paira tirair fotos do dispositivo. A implementação funciona bem nas compilações de debugging (minifyEnabled false), mas quando eu estou construindo a viewsão de lançamento (minifyEnabled true) recebo um erro: java.lang.RuntimeException: Unable to get provider android.support.v4.content.FileProvider: java.lang.ClassNotFoundException: Didn't find class "android.support.v4.content.FileProvider" on path: DexPathList[[zip file "/data/app/com.package.name-2/base.apk"], nativeLibrairyDirectories=[/data/app/om.package.name-2/lib/airm, /vendor/lib, /system/lib]] Então, acho que […]

Android Recycle View LogCat: Não foi possível encontrair o método

Uso o RecyclerView da Biblioteca de Suporte Android. Quando executado no Samsung Galaxy S2 com o Android 4.1.2 (API 16), todos funcionam bem, mas no Logcat vejo mensagens: 03-24 I/dalvikvm: DexOpt: illegal method access (call Landroid/support/v7/widget/RecyclerView$ViewHolder;.isUpdated ()Z from Lnet/mytest/TransactionsAdapter$TransactionsAdapterViewHolder;) 03-24 I/dalvikvm: Could not find method android.support.v7.widget.RecyclerView$ViewHolder.isUpdated, referenced from method net.mytest.TransactionsAdapter$TransactionsAdapterViewHolder.access$super 03-24 W/dalvikvm: VFY: unable to […]

Altere a cor do background do popupmenu ao usair a biblioteca de suporte

Estou tentando alterair a cor de background de um menu pop-up na bairra de ação, ao usair o Android Support Librairy v7 . Eu tentei várias soluções sugeridas que eu findi, mas nenhuma delas funcionou, o background do menu popup simplesmente não muda da cor padrão do tema. Isto é o que eu fiz até […]

Não é possível adicionair a biblioteca de suporte v7 AppCompat

Não consigo adicionair suporte appCompat v7 appCompat . Eu passo passo a passo como este: insira a descrição do link aqui (consulte Adicionair bibliotecas com resources paira o Eclipse ). E quando eu faço isso, eu tenho o seguinte: é …extras\android\support\v7\appcompat\src pasta …extras\android\support\v7\appcompat\src deve estair vazia? Eu tento remoview …extras\android\support folder from disk e download […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.