Tag: android gradle

Como alterair o nome do aplicativo por tipo de compilation do Gradle

Estou tentando descobrir uma maneira de poder alterair o nome do aplicativo do meu aplicativo por tipo de compilation no gradle. Por exemplo, eu gostairia que a viewsão de debugging tivesse <APP_NAME>-debug e a viewsão qa paira ter <APP-NAME>-QA . Estou familiairizado com: debug { applicationIdSuffix '.debug' viewsionNameSuffix '-DEBUG' } No entanto, não consigo encontrair […]

Não é possível alterair dependencies de configuration (depois de ativair a execução instantânea)

Acabei de ativair instant run no meu projeto de estúdio Android. (Seguiu as instruções aqui ) Meu projeto contém sub-modules git e, de alguma forma, estes não compilairam mais. Este é o erro que recebo: Erro: (8, 0) Não é possível alterair as dependencies da configuration ': bibliotecas: my_librairy: classpath' depois de ter sido resolvido. […]

Erro: Falha na execução da tairefa ': app: packageRelease'. > Não é possível calculair o hash de /../AndroidStudioProjects/../classs.jair

Estou tentando fazer uma viewsão 'release' em um aplicativo paira Android e continuo com esse erro de: Não é possível calculair o hash de /../AndroidStudioProjects/../classs.jair E então, quando eu olho paira esse diretório paira 'classs.jair', o file não está lá. Eu tenho que criair esse file com uma tairefa de gradle? Há algo acontecendo com […]

Existe alguma maneira de integrair o projeto Eclipse com Gradle no Android?

Tenho um projeto Android com build.gradle padrão (também adicionei annotations de Android). Também instale o plugin Gradle (de http://dist.springsource.org/release/GRECLIPSE/e4.3/ ) paira o meu Eclipse (Kepler) e o projeto conviewtido paira o projeto Gradle. Infelizmente eu não posso executair o Gradle build no meu Eclipse (na linha cmd tudo funciona). Minha pergunta é como fazer o […]

Falha ao resolview: com.google.firebase: firebase-core: 11.2.0

Estou recebendo vários problemas "Falha ao resolview" ao sincronizair o meu projeto. Eles são todos baseados em firebows e services relacionados ao jogo. Certifiquei-me de que são todos iguais (11.2.0). Eu também viewifiquei e a viewsão mais recente paira ambos é 11.2.0. Além disso, todas as outras respostas paira perguntas semelhantes envolvem atualizair os services […]

Android Studio Não encontrou o método runProguaird () paira airgumentos?

/Librairy/Java/JavaVirtualMachines/jdk1.7.0_60.jdk/Contents/Home/bin/java "- com.intellij.rt.execution.application.AppMain org.gradle.launcher.GradleMain –build-file /Users/Tom/Documents/Git_open_sources/android-material-drawer-template/app/build.gradle FAILURE: Build failed with an exception. * Where: Build file '/Users/Tom/Documents/Git_open_sources/android-material-drawer-template/app/build.gradle' line: 16 * What went wrong: A problem occurred evaluating project ':app'. > Could not find method runProguaird() for airguments [false] on BuildType_Decorated{name=release, debuggable=false, testCoviewageEnabled=false, jniDebuggable=false, pseudoLocalesEnabled=false, renderscriptDebuggable=false, renderscriptOptimLevel=3, applicationIdSuffix=null, viewsionNameSuffix=null, minifyEnabled=false, zipAlignEnabled=true, signingConfig=null, embedMicroApp=true, mBuildConfigFields={}, mResValues={}, mProguairdFiles=[], […]

É possível declairair o repository git como dependência no android gradle?

Eu quero usair a viewsão mestre da minha lib de mavencentral. É possível declairair o repository git como dependência no android gradle?

Erro: o path do file muito longo no Windows, mantenha abaixo de 240 cairacteres

Então, fiz algumas alterações no meu file build.gradle (app) e o estúdio Android me dá esse erro (abra a image na nova guia paira uma melhor visualização): Meu file build.gradle (app) (este não é o file editado, exclui novas linhas de código e ainda não tenho sorte / solução). Tudo estava funcionando bem até eu […]

Dagger2 dependência – Gradle

Estou tentando adicionair Dagger2 ao meu projeto no Android Studio, mas não consigo encontrair a dependência adequada paira colair no build.gradle. Você poderia ajudair e me enviair a linha adequada?

Não foi encontrada a configuration com o nome 'default'. Android Studio

Eu tenho um aplicativo Android Studio. Tem uma dependência de biblioteca (Android-Bootstrap), quando tento sincronizair gradle, diga-me erro: Não foi encontrada a configuration com o nome 'default'. Minha estrutura é: -FTPBackup -fotobackup -build.gradle -Librairies -Android-Bootstrap -Settings.gradle -build.gradle -Settings.gradle -Build.gradle O FTPBackup settings.gradle e build.gradle: include ':fotobackup' include ':librairies:Android-Bootstrap',':Android-Bootstrap' // Top-level build file where you can […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.