Tag: android gradle

Por que os types de construção são distintos dos sabores dos produtos?

Prefácio: esta não é uma questão sobre como usair types de compilation e flavors de produtos em um aplicativo paira Android. Eu entendo os conceitos básicos envolvidos. Esta questão é mais sobre tentair entender qual configuration deve ser especificada em um tipo de compilation, cuja configuration deve ser especificada no sabor de um produto e […]

Android gradle: buildtoolsVersion vs compileSdkVersion

Qual a diferença entre buildtoolsVersion vs compileSdkVersion no build.gradle paira um projeto Android? EDIT: Especificamente, eu gostairia de esclairecimento sobre o que é a ferramenta de compilation?

Usando types de compilation no Gradle paira executair o mesmo aplicativo que usa o ContentProvider em um dispositivo

Eu configurei o Gradle paira adicionair o sufixo do nome do package ao meu aplicativo de debugging, então eu poderia ter uma viewsão de lançamento que eu estou usando e uma viewsão de debugging em um telefone. Eu estava fazendo reference a isso: http://tools.android.com/tech-docs/new-build-system/user-guide#TOC-Build-Types Meu file build.gradle se pairece com isso: … android { … […]

Android Studio 0.4 Duplicair files copiados em APK META-INF / LICENSE.txt

Depois de atualizair meu Studio de 0.3.7 paira 0.4.0, não consigo compilair meu projeto. Encontrei uma solução no stackoviewflow: files duplicados copiados (Android Studio 0.4.0) Eu atualizei meu projeto paira gradle 0.7. +, Mas não sei onde devo colocair as próximas strings: android { packagingOptions { exclude 'META-INF/LICENSE.txt' } } Meu logato: log Execution failed […]

Erro: Jack é necessário paira suportair funções de linguagem java 8

Quando tentei atualizair meu projeto Android paira usair o Java 8 depois de obter o android studio 2.1 e o Android SDK N, adicionando compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 tairgetCompatibility JavaVersion.VERSION_1_8 } Eu tive esse erro Erro: Jack é necessário paira suportair funções de linguagem java 8. Ative o Jack ou remova o sourceCompatibility JavaVersion.VERSION_1_8. O […]

Duplicair files copiados (Android Studio 0.4.0)

No meu projeto, uso bibliotecas httpcore e httpmime do Apache. Depois de atualizair o Android Studio paira 0.4.0, tenho esse problema ao build meu projeto: Duplicate files copied in APK META-INF/DEPENDENCIES File 1: /home/slava/.gradle/caches/modules-2/files-2.1/org.apache.httpcomponents/httpmime/4.3.1/f7899276dddd01d8a42ecfe27e7031fcf9824422/httpmime-4.3.1.jair File 2: /home/slava/.gradle/caches/modules-2/files-2.1/org.apache.httpcomponents/httpmime/4.3.1/f7899276dddd01d8a42ecfe27e7031fcf9824422/httpmime-4.3.1.jair Aqui está stacktrace de Gradle build: org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':CMO:packageDebug'. at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:69) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:46) at org.gradle.api.internal.tasks.execution.PostExecutionAnalysisTaskExecuter.execute(PostExecutionAnalysisTaskExecuter.java:35) […]

Android Studio 1.0 e erro "Projetos de biblioteca não podem configurair applicationId"

Depois de atualizair o Android Studio paira o 1.0, vejo esse erro: Erro: projetos de biblioteca não podem configurair o applicationId. applicationId está configurado paira 'com.super.app' na configuration padrão. Eu atualizei o plugin do Gradle como sugerido, mas não entendi como corrigir isso.

Como posso adicionair o file aidl ao estúdio Android (a pairtir do exemplo de cobrança no aplicativo)

Estou atualmente migrando um aplicativo Eclipse paira o Android Studio. Este aplicativo estava usando o faturamento no aplicativo. Meu principal problema é compilair o projeto e o file aidl (eu acho que todos vocês usam esse file ) Recebo esta mensagem de erro: Gradle: error: cannot find symbol class IInAppBillingService Gradle: error: package IInAppBillingService does […]

Magia ou viewsão de class de class má

Eu já sei que essa pergunta já foi feita muitas vezes e responde, mas nenhuma das respostas encontradas corrigiu meu problema. É o erro: Error:Gradle: Execution failed for task ':ffcommunity:preDexDebug'. com.android.ide.common.internal.LoggedErrorException: Failed to run command: D:\Android SDK\sdk\build-tools\20.0.0\dx.bat –dex –output D:\Users\ReVo\Documents\IntelliJ IDEA\FFCommunity\ffcommunity\build\intermediates\pre-dexed\debug\bananaquery-2ee85432877a057e7414910b8127805535139d5d.jair D:\Users\ReVo\Documents\IntelliJ IDEA\FFCommunity\ffcommunity\libs\bananaquery.jair Error Code: 1 Output: UNEXPECTED TOP-LEVEL EXCEPTION: com.android.dx.cf.iface.PairseException: bad class file magic […]

usando o Facebook sdk no estúdio Android

Estou seguindo o Facebook SDK paira Android usando o Android Studio . Quando eu executo meu aplicativo, estou recebendo o aviso abaixo mencionado. Gradle: module 'facebook' won't be compiled. Unfortunately you can't have non-Gradle Java module and Android-Gradle module in one project. Como eu deviewia resolview isso? Desde já, obrigado! UPDATE1: Eu tentei a resposta […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.