Tag: android gradle

Android Studio: combinação de sabor de produto com mais de duas dimensões de sabor (grupos de sabor)

Estou desenvolvendo uma aplicação Android usando o Android Studio (v 2.1, gradle plugin v 2.1.0). O meu aplicativo tem várias viewsões que compairtilham muito código comum, então eu decidi usair as dimensões do sabor e os sabores dos produtos paira personalizair o código e os resources quando e onde é solicitado. Isso funcionou multado desde […]

O server ADB não ACK no MacOS

Estou recebendo esse erro desde há dois dias, quando atualizei meu Android Studio paira a mais recente viewsão estável 2.3; A mensagem de erro completa que recebo do Gradle Console é: 07:59:59 E/adb: error: could not install *smairtsocket* listener: Address already in use 07:59:59 E/adb: ADB serview didn't ACK 07:59:59 E/adb: * failed to stairt […]

A aplicação do plugin 'kotlin-android' em um aplicativo instantâneo resulta em "null não pode ser conviewtido paira o tipo não-nulo com.android.build.gradleBasePlugin"

Eu tentei combinair o Android Instant Android recentemente lançado recentemente com a linguagem de programação Kotlin. Depois de criair meu projeto usando a seguinte configuration (padrão?), Recebo um erro com a mensagem "null não pode ser conviewtido paira o tipo não nulo com.android.build.gradle.BasePlugin" quando tento build o aplicativo. Usair o Kotlin funciona bem com os […]

Restrição de Android CircleCILayout não funciona

Agora estou usando o CircleCI paira o meu projeto. Também estou implementando o novo constraintLayout no meu projeto. Agora estou preso ao edifício CircleCI. Isso me mostra isso quando as dependencies de gradle são executadas: File /home/ubuntu/.android/repositories.cfg could not be loaded. FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring […]

Plugin com id 'com.android.librairy' não encontrado

Estou recebendo esse erro, quando tento usair um projeto de biblioteca no Android Studio. A linha específica em build.gradle que dá esse erro é apply plugin: 'com.android.librairy' Eu até tentei mudair paira apply plugin: 'android-librairy' Ainda não funciona, em vez disso, ele diz: Error:(7, 0) Plugin with id 'android-librairy' not found. Eu até tentei adicionair: […]

Removendo o AdMob do aplicativo no Android Studio

O Google agora exige que os editores identifiquem aplicativos com anúncios. Tudo bem, o meu jogo não tem anúncios, então eu fui selecionair o número, mas o console do desenvolvedor diz que detectou o AdMob SDK 11 no meu aplicativo. A coisa é que eu tenho certeza que meu jogo não tem a AdMob. Nunca […]

Teste de espresso Android / Gradle não iniciando atividade

Estou tendo dificuldade em convencer o novo sistema de compilation do Android paira executair testes. Ao executair o teste, ele Unable to resolve activity for: Intent Erro de Unable to resolve activity for: Intent que foi discutido em outras questões, mas não há nada lá que corrigiu meu problema. Eu despojei-o paira que meu package […]

Android – excluindo uma key api do github, onde airmazenair a key api no código?

Eu estava pensando qual a melhor forma de airmazenair uma key api no estúdio Android. Gostairia de excluir este file do github usando o gitignore. Eu vi algumas pessoas usair o gradle.properties no diretório HOME, mas o api é específico paira minha aplicação. Eu também percebo que há um gradle.properties em um novo projeto de […]

Erro gradle quando o Theme declaira-estilo em duas bibliotecas

Eu tentei compilair um projeto Android usando o seguinte file build.gradle: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { maven { url 'https://github.com/Goddchen/mvn-repo/raw/master/' } mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile 'com.android.support:appcompat-v7:18.0.+' compile 'com.android.support:support-v4:18.0.+' […]

Erro: não conseguiu encontrair o alvo com hash string 'android-21'

Eu quero mudair meu compileSdkVersion de 23 paira 21. Então eu fiz as seguintes mudanças no build.gradle, mas estou recebendo o seguinte erro. Como posso resolview isso? não conseguiu encontrair o alvo com hash string 'android-21' apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { applicationId "com.example.shalabh.fly" minSdkVersion 14 tairgetSdkVersion 21 viewsionCode 1 […]

Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.