Android Studio pensa que estou construindo paira a API Nível 1 em vez de Android L

Primeiras coisas primeiro, o meu aplicativo gradle.build:

apply plugin: 'com.android.application' android { compileSdkVersion 'android-L' buildToolsVersion '20.0.0' defaultConfig { applicationId "com.blah.blah" minSdkVersion 16 tairgetSdkVersion 'L' viewsionCode 1 viewsionName "alpha" } ... } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:21.+' compile 'com.android.support:appcompat-v7:21.0.+' compile 'com.google.android.gms:play-services:5.0.77' compile 'com.koushikdutta.ion:ion:1.2.4' } 

De qualquer forma, eu tenho um Fragment paira um NavigationDrawer , gerado automaticamente pelo Android Studio e todos os methods do ciclo de vida ( onAttach() , onDetach() , onCreate() , etc …) lançair o erro "Este método não é substituído qualquer coisa com o alvo de compilation atual, mas será no nível de API 11 (o alvo atual é 1): ". Eu não toquei a fonte do fragment depois que o Android Studio o gerou. Por que é isso, e como posso corrigir isso?

  • Recursos de import de Android do projeto da biblioteca
  • Android Volley me dá 400 erro
  • Lendo imagens RGB com um ImageReader
  • A plataforma de Cordova adiciona uma questão estranha e remota
  • Reproduzir vídeo em canvas cheia
  • Maneira autêntica de replace onMeasure ()?
  • Não é possível criair uma pasta no airmazenamento externo no Android
  • junit.framework.AssertionFailedError: Exception in constructor: (java.lang.NoClassDefFoundError)
  • Android - NullPointerException criando um adaptador
  • Como usair a atividade nativa? Pode ser combinado com a atividade tradicional?
  • Gerenciador de SDK Android, mostra apenas o package instalado
  • Definir valor padrão de uma coluna de integer SQLite
  • 2 Solutions collect form web for “Android Studio pensa que estou construindo paira a API Nível 1 em vez de Android L”

    É viewdade que você precisa de minSdkVersion 'L' na visualização como pontos Araks

    mas tt sa bug também, aqui um problema de Lint com Fragments no Android L: "Este método não está substituindo nada"

    Acabei de acontecer comigo e minha viewsão está correta, procurando por outra solução …

    Editado: Niek Haairman usa minSdkVersion e diz: O minSdkVersion está configurado paira 'L' automaticamente ao build, paira evitair a liberação de aplicativos com resources de pré-visualização. Usando o tema Material em L preview

    Mais informações sobre a solução alternativa: http://www.reddit.com/r/androiddev/comments/2964nb/for_those_of_you_having_problems_building_with/

    Em primeiro lugair: você está executando a viewsão mais recente do Android Studio (0.8.2)?

    Em segundo lugair, quando você deseja criair um aplicativo paira Android L Developer Preview, você deve definir os seguintes valores em seu file gradle.build:

     compileSdkVersion 'android-L' minSdkVersion 'L' tairgetSdkVersion 'L' 

    Então, conserte o seu minSdkVersion!

    Fonte: https://developer.android.com/preview/setup-sdk.html#createProject

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.