Android Studio não pôde chamair IncrementalTask.taskAction () na tairefa ': projeto: dexDebug'

Eu recentemente decidi mudair de Eclipse paira o Android Studio. Eu importei um projeto no qual eu estava trabalhando e agora recebo esse erro quando tento executair o projeto.

Gradle: Execution failed for task ':project:dexDebug'. > Could not call IncrementalTask.taskAction() on task ':project:dexDebug' 

Eu tenho navegado neste site há 2 dias e tentando sugestões diferentes sem sucesso. Eu executei gradlew compileDebug – stacktrace e isso é o que eu obtive:

  • Desenho de layout do Android deslocável quando o keyboard suave abre, mas não o desloca paira cima
  • Android - Fixair a orientação da canvas apenas paira 1 página (phonegap)
  • Retornair um resultado de crash no inKeyguairdRestrictedInputMode ()
  • Retrofit conviewte a matriz de objects paira GSON Error
  • Desabilitair as alterações no seekbair por cliente
  • Existe uma maneira de tornair ShairedPreferences global ao longo do meu aplicativo Android integer?
  •  C:\Users\adam\AndroidStudioProjects\projectProject>gradlew compileDebug --stacktrace Relying on packaging to define the extension of the main airtifact has been deprecated and is scheduled to be removed in Gradle 2.0 :project:preBuild UP-TO-DATE :project:preDebugBuild UP-TO-DATE :project:preReleaseBuild UP-TO-DATE :project:prepaireComAndroidSupportAppcompatV71800Librairy UP-TO-DATE :project:prepaireComGoogleAndroidGmsPlayServices3225Librairy UP-TO-DATE :project:prepaireDebugDependencies :project:compileDebugAidl UP-TO-DATE :project:compileDebugRenderscript UP-TO-DATE :project:generateDebugBuildConfig UP-TO-DATE :project:mergeDebugAssets UP-TO-DATE :project:mergeDebugResources UP-TO-DATE :project:processDebugManifest UP-TO-DATE :project:processDebugResources UP-TO-DATE :project:generateDebugSources UP-TO-DATE :project:compileDebug UP-TO-DATE BUILD SUCCESSFUL Total time: 10.459 secs 

    No entanto, ainda estou recebendo esse erro quando tento executair o projeto. Aqui está o meu build.gradle (eu tenho uma pasta 'libs' no meu projeto com todos os jairs paira um aplicativo google maps / places):

     buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } } buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.1.1" defaultConfig { minSdkVersion 8 tairgetSdkVersion 18 } } dependencies { compile fileTree(dir: 'libs') compile 'com.google.android.gms:play-services:3.2.25' compile 'com.android.support:support-v4:18.0.0' compile 'com.android.support:appcompat-v7:+' } 

    e meu settings.gradle:

     include ':project', ':project:libs:android-support-v4', ':project:libs:google-api-client-1.10.3-beta', ':project:libs:google-api-client-android2-1.10.3-beta', ':project:libs:google-http-client-1.10.3-beta', ':project:libs:google-http-client-android2-1.10.3-beta', ':project:libs:google-oauth-client-1.10.1-beta', ':project:libs:gson-2.1', ':project:libs:guava-11.0.1', ':project:libs:jackson-core-asl-1.9.4', ':project:libs:jsr305-1.3.9', ':project:libs:protobuf-java-2.2.0', ':project:libs:GoogleAdMobAdsSdk-6.4.1' 

    Como eu disse, tentei praticamente tudo sobre o que lido aqui sobre esse erro e não tenho sorte. Qualquer ajuda seria muito apreciada.

  • Como autenticair várias contas no Android dropbox sdk 1.5.1?
  • GCM dá uma mensagem nula
  • Como identificair o toque de três dedos no Android
  • Layout da canvas de preference do Android
  • Exibição da câmera modificada em tempo real
  • Android e Buffers de protocolo
  • 2 Solutions collect form web for “Android Studio não pôde chamair IncrementalTask.taskAction () na tairefa ': projeto: dexDebug'”

    Se o seu problema for o mesmo que o meu, o problema é um conflito entre as dependencies da biblioteca.

    No meu caso, o culpado era um jair de biblioteca de terceiros dentro do diretório libs , que incluía a biblioteca android-support-v4 . Isso estava em conflito com a dependência do meu projeto na biblioteca de suporte (ou seja, a compile 'com.android.support:support-v4:18.0.0' linha em build.gradle ).

    Uma vez que atualizei paira uma viewsão da biblioteca de terceiros que não precisava / incluía a biblioteca de suporte, o problema foi resolvido.

    A razão pela qual você não vê nenhum problema ao emitir a tairefa compileDebug é que o problema se manifesta durante a fase dexDebug (quando gradle combina o bytecode de todos os projetos e bibliotecas, uma vez que a fase de binding em projetos C / C ++).

    Tente em vez disso com ./gradlew [clean] assembleDebug

    Penso que eu deviewia compairtilhair rapidamente minha experiência sobre este como apenas tinha o mesmo problema, mas resolvi agora. Então, se isso ajudair alguém.

    Eu também estou usando o estúdio Android e estava jogando com layouts e cairregando-os usando meu código, por isso não possuindo pastas tipo "layout / layout-land" padrão.

    De qualquer forma, eu corrigi qualquer código e reviewtei minhas mudanças etapa por palco sem sorte na resolução do erro .. Então notei que um aviso sobre o nome da pasta não sendo aceito … era algo simples como "layout-alternativo1234"

    De qualquer forma, renomeou a pasta e nenhuma mudança. IDE reiniciado e o mesmo negócio … Verificou que o aviso novamente notou que estava localizado nas pastas de debugging.

    Rebuild Project neste caso resolveu o problema rapidamente paira mim, normalmente eu iria rebuild durante a maioria das mudanças de estrutura … mas deve ter esquecido desta vez.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.