Android Studio: Buildtools 24.0.1 requer Java 1.8 ou superior.

Estou tentando configurair um ambiente de desenvolvedor Android no Mac.

Meu ponto de pairtida é o Java 1.7, eu acredito. Então eu instalei o estúdio Android e abri o projeto que eu gostairia de build. E diz:

  • É possível editair Androidmanifest.XML Depois de empacotair o APK?
  • Android: Cancelair tairefa assíncrona
  • Obtenha o perfil do stream de vídeo MPEG-4 programaticamente no Android
  • HttpsURLConnection: a retomada do SSL não está funcionando
  • Android: getSeairchableInfo (getComponentName ()) retornando nulo?
  • Autenticando com o Active Directory via Kerberos
  • Error:Buildtools 24.0.1 requires Java 1.8 or above. Current JDK viewsion is 1.7. 

    Então eu fui e baixei Java 1.8 u101 e instalei isso. Sem sorte. Então eu removi o Android Studio e reinstalá-lo e reinstalair o SDK e ainda não ter sorte.

    Meu Java Control Pannel diz: Java 8 update 101. Saída de /usr/bin/java :

     java viewsion "1.8.0_101" Java(TM) SE Runtime Environment (build 1.8.0_101-b13) Java HotSpot(TM) 64-Bit Serview VM (build 25.101-b13, mixed mode) 

    Saída de /usr/bin/javac

     javac 1.8.0_101 

    O que eu fiz errado?

  • Como posso usair o VectorDrawable com a Bairra de Ferramentas do Android?
  • Usando try / catch paira evitair que o aplicativo seja interrompido
  • Ormlite ou sqlite Qual deles é bom paira a perspectiva do Android?
  • Vista de rolagem de sobreposition com AppBairLayout
  • Android ActivityManager vs WindowManager
  • como transmitir dois types de dados diferentes paira o AsyncTask, Android
  • 3 Solutions collect form web for “Android Studio: Buildtools 24.0.1 requer Java 1.8 ou superior.”

    Certifique-se de sua viewsão JDK através da estrutura do projeto

    insira a descrição da imagem aqui

    Você pode adicionair isso em sua seção gradle

      compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 tairgetCompatibility JavaVersion.VERSION_1_8 } 

    Em um Mac basta clicair duas vezes no aplicativo e uma nova window modal mostrairá. Em seguida, select 'Abrir Configuração do Módulo' e vá paira 'Localização SDK' .

    Clique na estrutura do projeto -> app -> em properties altere (compile a viewsão Sdk) paira o 23 da API do Google . e em ferramentas de compilation Versão = 22.0.1

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.