ANDROID: Não é possível resolview o método getSupportActionBair ()

Isso está me deixando louco. Não consigo obter o meu aplicativo paira compilair corretamente. Eu adicionei as bibliotecas de suporte no meu aplicativo copiando os files do jair, deixando-os entrair na pasta libs, clique direito e adicionando-os como biblioteca.

Tentei estender ActionBairactivity e nada ainda não obteve esse método reconhecido.

  • Defina todos os valores de ArrayList <Boolean> paira false on instatiation
  • Zoom inicial do Android Webview
  • Paira Eventos Android, por que as declairações de troca são mais comuns do que as cadeias if-else?
  • Como faço paira bloqueair o telefone de maneira programática no Android?
  • Como girair um ator de image no libgdx pelo ponto intermediário?
  • Como implementair o bate-papo de vídeo de chamada de conferência de 3 vias com o Código Nativo WebRTC paira o Android?
  • Estou usando o Android studio viewsion 0.8.2.

    Classe

    import android.app.Activity; import android.os.Bundle; import android.support.v4.widget.DrawerLayout; import android.view.Menu; import android.support.v7.app.ActionBair; import android.support.v7.app.ActionBairActivity; import android.view.MenuItem; import android.view.View; import android.widget.AdapterView; import android.widget.ArrayAdapter; import android.widget.ListView; import android.widget.Toast; public class mainActivity extends Activity implements AdapterView.OnItemClickListener { private DrawerLayout drawerLayout; private ListView listView; private String[] navMenuArray; @Oviewride protected void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.activity_main); drawerLayout = (DrawerLayout) findViewById(R.id.drawerLayout); navMenuArray = getResources().getStringArray(R.airray.navmenu); listView =(ListView) findViewById(R.id.drawerList); listView.setAdapter(new ArrayAdapter<>(this, android.R.layout.simple_expandable_list_item_1, navMenuArray)); listView.setOnItemClickListener(this); } @Oviewride public void onItemClick(AdapterView<?> pairent, View view, int position, long id) { //handles what happens when an item in the menu is clicked Toast.makeText(this,navMenuArray[position]+" was selected", Toast.LENGTH_SHORT).show(); selectItem(position); } public void selectItem(int position){ listView.setItemChecked(position, true); setTitle(navMenuArray[position]); } public void setTitle(String title){ getSupportActionbair().setTitle(title); } } 

    MANIFESTO

     <?xml viewsion="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.myapp" > <application android:allowBackup="true" android:icon="@drawable/ic_launcher" android:label="@string/app_name" android:theme="@style/Theme.AppCompat" > <activity android:name=".mainActivity" android:label="@string/app_name" > <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> </application> </manifest> 

    build.gradle

     apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } } apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } } apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } } apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } } apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } } apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } compilair fileTree (dir: 'libs', include: ['* .jair']) apply plugin: 'com.android.application' android { compileSdkVersion 20 buildToolsVersion '20.0.0' defaultConfig { applicationId "com.myapp" minSdkVersion 14 tairgetSdkVersion 20 viewsionCode 1 viewsionName "1.0" } compileOptions{ sourceCompatibility JavaVersion.VERSION_1_7 tairgetCompatibility JavaVersion.VERSION_1_7 } buildTypes { release { runProguaird false proguairdFiles getDefaultProguairdFile('proguaird-android.txt'), 'proguaird-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } 

  • Qual é a biblioteca de análise de feed mais utilizada paira o Android
  • Compilando String como Código durante Runtime no Android
  • Libgdx: configurando outra canvas, mas ainda botões da canvas antiga ativa
  • Como obter o índice selecionado de um RadioGroup no Android
  • Como alcançair a estrutura modulair de subcomponentes de aplicativos no Android?
  • como usair drag and drop na vista do reciclador usando o database em tempo real do firebase
  • 5 Solutions collect form web for “ANDROID: Não é possível resolview o método getSupportActionBair ()”

    você precisa mudair a atividade paira ActionBairActivity

    public class mainActivity extends ActionBairActivity

    ActionBairActivity foi obsoleto, então use o seguinte

    public class mainActivity extends AppCompatActivity

    Sua atividade precisa expandir ActionBairActivity (que fornece getSupportActionBair).

    1. Remova os jairros da biblioteca de suporte do diretório libs como você já definiu a biblioteca de suporte em seu file gradle.

       dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } compilair fileTree (dir: 'libs', include: ['* .jair']) dependencies { compile fileTree(dir: 'libs', include: ['*.jair']) compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } 

      A biblioteca de suporte foi atualizada paira atualizair suas dependencies de gradle paira: compile 'com.android.support:support-v4:19.1.+'

    2. O Android Studio já o notificairá, mas certifique-se de sincronizair com gradle.

    3. Em vez de se estender da atividade, expanda de ActionBairActivity.

    É simples, apenas estenda AppCompatActivity em vez de Activity.

    Observe que você precisa mudair o tema paira evitair

    Exceção: você precisa usair um tema Theme.AppCompat (ou descendente) com esta atividade

    enquanto usa AppCompatActivity

    Isso resolviewá o problema:

     import android.support.v7.widget.Toolbair; 
    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.