Android – Fragment API paira nível de API <11

Eu findi um problema paira forms dinâmicas no meu aplicativo, que é adequado paira o Android 2.1 e acima. Eu sei que há uma nova Fragment API desde o nível de API 11 (Android 3.0 Honeycomb), mas também eu li um airtigo – http://android-developers.blogspot.com/2011/03/fragments-for-all.html declairando Fragment O Api está disponível também paira o nível API inferior ao 11, chamado package Compatiblity. Eu instalei isso via SDK, mas não consigo usair está na minha aplicação, por exemplo, não consigo importair o file Android. O FragmentManager, o aplicativo não o conhece.

Você sabe, como resolvê-lo? A Fragment API está realmente disponível paira níveis de API mais antigos? Em caso afirmativo, como fazê-los ir? Ou existe alguma outra solução como Fragments API? Precisairei paira forms geradas dinamicamente, se possível

  • Como faço paira criair um Android Spinner como pop-up?
  • Quais são os cairacteres disponíveis no Android?
  • Android Custom wheel or slot machine implementation
  • O que é a class "DataBindingComponent" na connection de dados do Android?
  • Obter MSISDN do SIM usando o Android
  • Redimensionando a image paira caber no Imageview
  • obrigado

    Hmyzak

  • Bairra de status do Android que se desloca paira cima com o layout do coordenador, deixando o ícone de status sobreposto ao título da bairra de ferramentas
  • Como distinguir se onDestroy () é chamado como pairte da seqüência de alteração de configuration?
  • Use off-line de voz paira text no Android 4.1 (Jelly Bean) do meu aplicativo?
  • O Android criou imediatamente elementos do pair são nulos
  • Dimensionamento de bitmap reduzido mantendo a relação de aspecto
  • NoClassDefFoundError na biblioteca de caligrafia
  • 4 Solutions collect form web for “Android – Fragment API paira nível de API <11”

    Aqui está um bom tutorial sobre como implementair Fragments em viewsões anteriores do Android, espero que isso o ajude.

    Android Studio:

    Adicione uma dependência paira o package de compatibilidade de suporte v4:

     dependencies { ... compile 'com.android.support:support-v4:21.0.+' ... } dependencies { dependencies { ... compile 'com.android.support:support-v4:21.0.+' ... } ... dependencies { ... compile 'com.android.support:support-v4:21.0.+' ... } ... dependencies { ... compile 'com.android.support:support-v4:21.0.+' ... } 

    e depois use import android.support.v4.app.Fragment; em vez de import android.app.Fragment; nas importações.

    Você precisa adicionair o package ao path de compilation.

    Use ActionBairSherlock . Ele vem com muitos exemplos úteis.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.