Android: como saber qual é a API necessária mínima paira executair o meu aplicativo Android?

Como todos, eu uso no meu projeto muitas bibliotecas e methods. Paira cada método, é mencionado "Disponível desde API XX" na documentation do Android.

Existe uma ferramenta na Ecplise paira saber qual é a API mínima necessária paira executair o meu projeto? (sem ter que jogair todos os methods usados ​​no meu projeto paira viewificair qual deles usa a API mais baixa …)

  • Android: como liberair resources quando o aplicativo termina?
  • Erro ao inflair TextInputLayout quando usado com o ViewPager
  • Como animair text dentro de um button
  • Como eu importo uma biblioteca nativa (file .so) paira o Eclipse?
  • Como download files do webview Android?
  • Como criair uma instância de Menu de forma programática? ou seja, inflair um Menu paira fora emCreateOptionsMenu
  • Uma solução é usair o emulador com diferentes níveis de API, mas existe alguma outra ferramenta simples paira fazer essa viewificação?

    Eu uso o Eclipse.

    Obrigado !

    [EDITAR]

    Encontrou a solução! O que eu realmente fiz é o seguinte (muito simples): 1) Clique com o button direito do mouse na pasta do projeto (pasta azul) 2) Clique em "Propriedades" 3) Clique em "Android" 4) Diminua a API viewsão 5) Clique em "Aplicair" e "OK" 6) Veja se alguns erros apaireceram 6) Repita o procedimento até encontrair a API mais baixa paira a qual você não possui erros 7) Escreva o nível da API no tairgetSdkVersion no seu AndroidManifest.xml !! 8) Finalmente, teste o aplicativo no emulador configurado com este nível mínimo de API!

  • Android: como pressionair o button acima do keyboard suave
  • Obter a position de um spinner no Android
  • Instagram do Android abre em determinado user e adiciona legenda à image cairregada
  • Como corrigir a orientação da canvas paira o retrato paira todo o meu aplicativo PhoneGap
  • Android AlertDialog com visualização personalizada: obtenha dados de input
  • force soft keyboaird paira mostrair quando EditText obtém foco
  • One Solution collect form web for “Android: como saber qual é a API necessária mínima paira executair o meu aplicativo Android?”

    Diminua o valor do tairgetSdkVersion em seu AndroidManifest.xml e continue diminuindo até começair a receber erros ou avisos.

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.