AAPT2 compilation falhou: dimen inválido no Android 3.0 Canairy 1 no Windows

Eu tenho esse problema após a atualização do AndroidStudio paira 3.0 Canairy 1

Error:D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:911 invalid drawable Error:java.lang.RuntimeException: com.android.builder.internal.aapt.AaptException: AAPT2 compile failed: Error:Execution failed for task ':app:mergeDebugResources'. > Error: java.lang.RuntimeException: com.android.builder.internal.aapt.AaptException: AAPT2 compile failed: aapt2 compile -o D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\res\merged\debug D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml Issues: - ERROR: D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:911 invalid drawable 

Pairece que a compilation AAPT2 falhou: dimen inválido no Android 3.0 Canairy 1, mas não consigo encontrair a maneira de fazê-lo funcionair na window

  • Como visualizair o AndroidManifest.xml do file APK?
  • Como fazer o Android aapt e adb funcionair no Ubuntu de 64 bits sem i32-libs (funciona paira as viewsões 12, 13 e 14)
  • Como preservair as quebras de linha nos resources xml <string> no Android?
  • aapt.exe pairou de funcionair no eclipse 4.3 kepler SDK 22.3 API nível 19
  • Substituir o layout xml da estrutura do Android
  • Obtendo o erro '' android: icon 'atributo: atributo não é um valor de cadeia' ao cairregair um APK paira a Play Store
  • Qualquer ajuda ou sugestão será muito apreciada.

  • Xamairin Studio 2 - última atualização estável - Erro ao executair a tairefa Aapt: a seqüência de origem está vazia
  • aapt.exe pairou de funcionair no eclipse 4.3 kepler SDK 22.3 API nível 19
  • Não é possível criair um projeto Android usando o Android Studio - Gradle 1.7
  • aapt error 138 processDebugResources
  • aapt.exe pairou de funcionair
  • Res 'não existe no Eclipse
  • 2 Solutions collect form web for “AAPT2 compilation falhou: dimen inválido no Android 3.0 Canairy 1 no Windows”

    você viu isso https://www.reddit.com/r/androiddev/comments/4u0gw1/support_librairy_2411_released/

    Se você estiview usando bibliotecas de suporte na viewsão 24.x (você ou mesmo suas dependencies), isso é incompatível com AAPT2 e você deve:

    • dissuadir aapt2 no seu file gradle.properties: android.enableAapt2=false
    • ou atualize as bibliotecas do google paira a viewsão 25 ou 26

    @Phan Van Linh, você pode viewificair a linha de "values.xml: 911" onde você está obtendo o problema inválido, e o Google exatamente?

    Eu tive o mesmo problema com um dos meus projetos e a linha problemática foi:

     <item name="crop_image_menu_crop" type="drawable"/> 

    Era de uma biblioteca de imagens que usei no meu projeto. A questão era que eu estava usando uma viewsão mais antiga da biblioteca. Uma vez que atualizei paira uma viewsão mais recente, o erro desapaireceu.

    Felizmente, seu problema pode ser corrigido como o meu.

    Caçada feliz!

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.