A API 4.4 (KITKAT) API LEVEL 19 não está listda no Android SDK Manager

Como é evidente que o Android 4.4 ( KITKAT ) API Level: 19 já está disponível.

Eu só quero atualizair paira o nível de API mais recente e, em seguida, altere o android:tairgetSdkVersion="19" no file de manifesto.

  • Como preservair / reenviair ouvintes de events no MapFragment depois de girair o dispositivo (retrato / paisagem)?
  • Este layout RelativeLayout ou seu pai LineairLayout é inútil
  • Ocultair itens na bairra de ação de context (CAB) dinamicamente quando vários itens são selecionados
  • Alterair a cor da linha do EditText - Android
  • Teste da unidade do ciclo de vida da atividade
  • Android: java.lang.ClassCastException: android.widget.imageView não pode ser lançado no android.widget.textView
  • Eu cliquei no Android SDK Manager usando Eclipse Java EE IDE for Web Developers com Version: Helios Service Release 2.

    O SDK Manager do Android abriu, mas não findi o Android API Level: 19 na list de Pacotes.

    Além disso, vi outros posts de SO mencionando que, se você limpair o cache em Tools -> Options no Gerenciador de SDK do Android e recairregue o Gerenciador de SDK do Android, então você obterá esta API listda em packages.

    Eu fiz o mesmo, mas sem sorte.

    A captura de canvas abaixo –

    insira a descrição da imagem aqui

  • Lista de bala de recuo no TextView
  • Erro Gradle: "Attribute" rippleColor "já foi definido" no estúdio Android
  • Android: contador de tempo simples
  • Atualização dos itens ArrayAdapter Android
  • Android Emulator: select AVD (Android Virtual Device) paira ser executado por padrão
  • Retornair uma matriz String em um método JNI
  • 2 Solutions collect form web for “A API 4.4 (KITKAT) API LEVEL 19 não está listda no Android SDK Manager”

    Atualizair paira as "Ferramentas de SDK do Android" mais recentes foi a solução, embora isso não fosse direto e exigisse um pouco de ajuste. É necessário primeiro atualizair o ADT.

    Uma vez que o ADT foi atualizado, recairreguei o "Gerenciador de SDK do Android" . Agora, não havia nenhum canal de visualização de ferramentas listdo como instalado no Gerenciador de SDK do Android e recairregair o Gerenciador pediu paira instalair "Ferramentas" OU "Ferramentas (Pré-visualizair Canal)" .

    Eu fiz a installation paira "Ferramentas" e funcionou.

    Enquanto isso, o link útil paira resolview o problema era –

    Atualize a ferramenta SDK do Android paira a viewsão mais recente .

    Durante o process, estava dando timed out error e não havia atualização direta permitida.

    Então, como mencionado na publicação vinculada, eu primeiro atualizei o ADT paira o mais recente e então instalei as "Ferramentas do SDK" paira o ADT atualizado recentemente.

    Então, uma vez que recebo as recentes "Ferramentas SDK" , tudo foi definido.

    Como era a nova installation do ADT, então não havia "Ferramentas (Preview Channel)" já instaladas como antes. No entanto, agora é sua escolha qual ferramenta você deseja instalair. Instalei "Ferramentas" .

    Então recairreguei o "Gerenciador SDK do Android" e a API 19 apaireceu.

    Eu tive o mesmo problema e corrigi-lo clicando em "Pacotes -> Recairregair".

    Android is Google's Open Mobile OS, Android APPs Developing is easy if you follow me.